Project

General

Profile

Bug #173340

SVN repository feature is broken

Added by Hebert Caballero @ 1Publicidad about 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Urgent
Category:
External Repository
Target version:
Start date:
2013-04-29
Due date:
% Done:

0%

Estimated time:

Description

This morning repositories are returning 404 error "The entry or revision was not found in the repository".

History

#1 Updated by Brad Rushworth about 6 years ago

  • Status changed from New to Resolved

It looks like it is only affecting your account? Something to do with your repository.

If you can't fix it yourself (maybe it is your username/password for the repository), let me know and I'll look at it in about 12 hours.

The error is:

Processing RepositoriesController#show (for 174.136.100.197 at 2013-04-30 07:54:24) [GET]
  Parameters: {"action"=>"show", "id"=>"kimberly-clark_colombia_-_templates", "controller"=>"repositories"}
Error parsing svn output: #<REXML::ParseException: No close tag for /lists/list>
/usr/local/lib/ruby/1.8/rexml/parsers/treeparser.rb:28:in `parse'
/usr/local/lib/ruby/1.8/rexml/document.rb:227:in `build'
/usr/local/lib/ruby/1.8/rexml/document.rb:43:in `initialize'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.15/lib/active_support/xml_mini/rexml.rb:17:in `new'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.15/lib/active_support/xml_mini/rexml.rb:17:in `parse'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.15/lib/active_support/xml_mini.rb:12:in `__send__'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.15/lib/active_support/xml_mini.rb:12:in `parse'
/usr/local/www/hostedredmine.com/redmine/lib/redmine/scm/adapters/subversion_adapter.rb:106:in `entries'
/usr/local/www/hostedredmine.com/redmine/lib/redmine/scm/adapters/abstract_adapter.rb:230:in `call'
/usr/local/www/hostedredmine.com/redmine/lib/redmine/scm/adapters/abstract_adapter.rb:230:in `shellout'
/usr/local/www/hostedredmine.com/redmine/lib/redmine/scm/adapters/abstract_adapter.rb:227:in `popen'
/usr/local/www/hostedredmine.com/redmine/lib/redmine/scm/adapters/abstract_adapter.rb:227:in `shellout'
/usr/local/www/hostedredmine.com/redmine/lib/redmine/scm/adapters/abstract_adapter.rb:210:in `shellout'
/usr/local/www/hostedredmine.com/redmine/lib/redmine/scm/adapters/subversion_adapter.rb:100:in `entries'
/usr/local/www/hostedredmine.com/redmine/app/models/repository.rb:192:in `entries'
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.15/lib/active_record/associations/association_proxy.rb:215:in `send'
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.15/lib/active_record/associations/association_proxy.rb:215:in `method_missing'
/usr/local/www/hostedredmine.com/redmine/app/controllers/repositories_controller.rb:93:in `show'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/base.rb:1333:in `send'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/base.rb:1333:in `perform_action_without_filters'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/filters.rb:617:in `call_filters'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/filters.rb:610:in `perform_action_without_benchmark'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/benchmarking.rb:68:in `perform_action_without_rescue'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.15/lib/active_support/core_ext/benchmark.rb:17:in `ms'
/usr/local/lib/ruby/1.8/benchmark.rb:308:in `realtime'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.15/lib/active_support/core_ext/benchmark.rb:17:in `ms'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/benchmarking.rb:68:in `perform_action_without_rescue'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/rescue.rb:160:in `perform_action_without_flash'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/flash.rb:151:in `perform_action'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/base.rb:532:in `send'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/base.rb:532:in `process_without_filters'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/filters.rb:606:in `process'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/base.rb:391:in `process'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/base.rb:386:in `call'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/routing/route_set.rb:438:in `call'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/dispatcher.rb:87:in `dispatch'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/dispatcher.rb:121:in `_call'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/dispatcher.rb:130:in `build_middleware_stack'
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.15/lib/active_record/query_cache.rb:29:in `call'
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.15/lib/active_record/query_cache.rb:29:in `call'
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.15/lib/active_record/connection_adapters/abstract/query_cache.rb:34:in `cache'
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.15/lib/active_record/query_cache.rb:9:in `cache'
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.15/lib/active_record/query_cache.rb:28:in `call'
/usr/local/lib/ruby/gems/1.8/gems/activerecord-2.3.15/lib/active_record/connection_adapters/abstract/connection_pool.rb:361:in `call'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/string_coercion.rb:25:in `call'
/usr/local/lib/ruby/gems/1.8/gems/rack-1.1.6/lib/rack/head.rb:9:in `call'
/usr/local/lib/ruby/gems/1.8/gems/rack-1.1.6/lib/rack/methodoverride.rb:24:in `call'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/params_parser.rb:15:in `call'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/session/cookie_store.rb:99:in `call'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/failsafe.rb:26:in `call'
/usr/local/lib/ruby/gems/1.8/gems/rack-1.1.6/lib/rack/lock.rb:11:in `call'
/usr/local/lib/ruby/gems/1.8/gems/rack-1.1.6/lib/rack/lock.rb:11:in `synchronize'
/usr/local/lib/ruby/gems/1.8/gems/rack-1.1.6/lib/rack/lock.rb:11:in `call'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.15/lib/action_controller/dispatcher.rb:106:in `call'
/usr/local/lib/ruby/gems/1.8/gems/rack-1.1.6/lib/rack/content_length.rb:13:in `call'
/usr/local/lib/ruby/gems/1.8/gems/rack-1.1.6/lib/rack/handler/fastcgi.rb:57:in `serve'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.15/lib/fcgi_handler.rb:103:in `process_request'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.15/lib/fcgi_handler.rb:153:in `with_signal_handler'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.15/lib/fcgi_handler.rb:101:in `process_request'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.15/lib/fcgi_handler.rb:78:in `process_each_request'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.15/lib/fcgi_handler.rb:77:in `each'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.15/lib/fcgi_handler.rb:77:in `process_each_request'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.15/lib/fcgi_handler.rb:76:in `catch'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.15/lib/fcgi_handler.rb:76:in `process_each_request'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.15/lib/fcgi_handler.rb:51:in `process!'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.15/lib/fcgi_handler.rb:23:in `process!'
/usr/local/www/hostedredmine.com/redmine/public/dispatch.fcgi:24
...
No close tag for /lists/list
Line: 
Position: 
Last 80 unconsumed characters:
Output was:
 <?xml version="1.0" encoding="UTF-8"?>
<lists>
<list
   path="https://subversion.assembla.com/svn/KCC-templates">
Rendering template within layouts/base
Rendering common/error (404)
Completed in 720ms (View: 59, DB: 20) | 404 Not Found [http://www.hostedredmine.com/projects/kimberly-clark_colombia_-_templates/repository]

#2 Updated by Hebert Caballero @ 1Publicidad about 6 years ago

I tested two of my repositories: i can access them in the browser providing the username and password and everything is ok, i can access them with svn and tortoisesvn too.

But i can't still access them here.

They're placed in Assembla.com. You can create a private repository there for free if you need to test.

Could it be possible that Assembla became unreachable from HostedRedmine?

#3 Updated by Bertrand MOREAU about 6 years ago

Good morning.
I created a new account/project (Little Blue RTOS) and it seems I get the same problem
I Cannot have external access to my SVN repository with redmine . https://xp-dev.com/svn/LittleBlueRTOS

It is working fine with tortoise SVN , eclipse (subclipse) or web access.

#4 Updated by Brad Rushworth about 6 years ago

  • Status changed from Resolved to Assigned

Yes, I apologise. We definitely have a problem on our end. I'll look into it now.

#5 Updated by Brad Rushworth about 6 years ago

We seem to be having problems only with secure HTTPS repositories. As a work-around, you can use the unencrypted HTTP version of the repository URLs. We once had a similar problem in the past (#118). I'll try to fix this later today.

#6 Updated by Brad Rushworth about 6 years ago

  • Status changed from Assigned to Resolved

I think I've fixed it. All but one of your repositories are now working (perhaps you have the password incorrect)?

#7 Updated by Brad Rushworth about 6 years ago

Is this now working for everyone?

By the way, I didn't mention that the problem was triggered over the weekend when we did extensive upgrades on all our software versions.

https://www.hostedredmine.com/news/1534

#8 Updated by Bertrand MOREAU about 6 years ago

Well done. It is working now
All my best

#9 Updated by Hebert Caballero @ 1Publicidad about 6 years ago

Yes, it is working now... sadly it seems we lost the revisions-issues references... Having to recreate them by hand again.

#10 Updated by Hebert Caballero @ 1Publicidad about 6 years ago

Thanks. We can recreate the issues, because we know we were editing the issues in the mean time, maybe deleting the references with no intention.

#11 Updated by Brad Rushworth about 6 years ago

Desarrollo 1Publicidad wrote:

Thanks. We can recreate the issues, because we know we were editing the issues in the mean time, maybe deleting the references with no intention.

Hopefully this is working for you now. I did notice a few more problems with subversion that I've just fixed.

#12 Updated by Hebert Caballero @ 1Publicidad about 6 years ago

As a small question. Do issue - revision relationships on not-edited issues/revisions get back? or are they lost?

#13 Updated by Brad Rushworth about 6 years ago

Desarrollo 1Publicidad wrote:

As a small question. Do issue - revision relationships on not-edited issues/revisions get back? or are they lost?

I don't see why they would be broken. Perhaps try removing your repository from Redmine and then adding it back in again. That way it will reload all the repository information and recreate the lost relationships?

#14 Updated by Hebert Caballero @ 1Publicidad about 6 years ago

Brad Rushworth wrote:

Desarrollo 1Publicidad wrote:

As a small question. Do issue - revision relationships on not-edited issues/revisions get back? or are they lost?

I don't see why they would be broken. Perhaps try removing your repository from Redmine and then adding it back in again. That way it will reload all the repository information and recreate the lost relationships?

I'd try and will come back if anything goes wrong or weird.
Thanks for your help.

#15 Updated by Brad Rushworth about 6 years ago

  • Status changed from Resolved to Closed

#16 Updated by Masaki Gondo about 6 years ago

Hi,

I am experiencing exactly the same problem now.
It worked fine several days ago when I first configured it, but suddenly it started to return 404.

I am using the Assembla service over https as above.

Anyway the fix was averted by any recent changes?

Regards,

Masaki

#17 Updated by Brad Rushworth about 6 years ago

Sorry, I patched a security vulnerability yesterday and broke it. I have now corrected the mistake.

#18 Updated by Masaki Gondo about 6 years ago

Hi Brad,

Thanks, it is back on and working again.

Amazingly fast support!

Regards,

Masaki

On Jun 29, 2013, at 10:27, "HostedRedmine.com"
wrote:

Issue #173340 has been updated by Brad Rushworth.

Sorry, I patched a security vulnerability yesterday and broke it. I have
now corrected the mistake.
------------------------------
Bug #173340: SVN repository feature is
broken

- Author: Desarrollo 1Publicidad
- Status: Closed
- Priority: Urgent
- Assignee: Brad Rushworth
- Category: External Repository
- Target version: Maintenance

This morning repositories are returning 404 error "The entry or revision
was not found in the repository".
------------------------------

You can reply to this email and it will be added to the issue log within a
few minutes.

You have received this notification because you have either subscribed to
it, or are involved in it.
To change your notification preferences, please click here:
https://www.hostedredmine.com/my/account

Also available in: Atom PDF