Project

General

Profile

Bug #656549

Middle-click tile info box has no background

Added by S.C. L. over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Category:
gui-gtk-3.22
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

When middle-clicking a tile on the map, a box containing various information on the tile appears. In the 2.6.0-beta0+r35254 gtk+3.22 client (and an earlier gtk+3 client whose revision number I can't recall), this box has a transparent background, making it hard to discern its contents in front of the terrain behind it.

History

#1 Updated by Marko Lindqvist about 3 years ago

Was this on Windows? Since it's gtk3.22-client, it can't be msys1 build, though.

#2 Updated by S.C. L. about 3 years ago

Windows 10 and yeah, msys2. Just tested it again, the problem persists in 2.6.0-beta0+c0e0c9a632-msys2-win64-gtk3.22.

#3 Updated by Marko Lindqvist about 3 years ago

Can someone test if msys1 (and gtk3-client), with its older gtk+ version, is affected. There's build 2.6.0-beta0+6586576b2f currently at http://files.freeciv.org/packages/windows/testing/cazfi/installer_msys1/

#4 Updated by Jacob Nevins about 3 years ago

On my 32-bit Windows 7 system, S2_6 + msys1 + Gtk3 doesn't show this symptom (and for completeness, neither do S2_5 post-Git or 2.5.7).

However, I can't confirm the original issue, because I can't install msys2 builds, as they are 64-bit only.

The build I tried describes itself as:

This is Freeciv version 2.6.0-beta0 (beta version), gui-gtk-3.0 client.
Built against gtk+ 3.8.2, using 3.8.2
Built against glib 2.36.1, using 2.36.1

#5 Updated by Jacob Nevins about 3 years ago

FWIW, we had trouble with these popups before (black rather than transparent): see Gtk minefield. (msys1 builds are still using the Gtk3 version that we settled on back then.)

#6 Updated by Marko Lindqvist about 3 years ago

Reproduced with
S2_6 / msys2 environment 170707 / win32 target / gtk3-client

#7 Updated by Marko Lindqvist about 3 years ago

  • Status changed from New to In Progress

We call gtk_widget_set_app_paintable() for tile info window, meaning that we specifically ask gtk+ not to draw background for us. We then don't do the drawing ourselves either. Apparently this has an undefined result - in most systems it results in black background, but transparent on some.

#9 Updated by Marko Lindqvist about 3 years ago

#10 Updated by Marko Lindqvist about 3 years ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

Also available in: Atom PDF