Project

General

Profile

Bug #756718

Multiplayer: Small Wonders buy cost halved

Added by S.C. L. about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
General
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

This is directly caused by by the fix to Bug #706727.

In the multiplayer ruleset, this change heavily impacted the balance by effectively making small wonders (i.e. almost all wonders in the ruleset) more powerful, especially under trade-oriented economies.


Related issues

Related to Freeciv - Bug #706727: Small Wonders buy cost doubledClosed

Blocks Freeciv - Task #656466: S3_0 datafile format freeze (d3f)Closed2019-10-05

Blocks Freeciv - Feature #767397: Double buy cost of Small Wonders in multiplayer rulesetClosed

History

#1 Updated by S.C. L. about 2 years ago

  • Related to Bug #706727: Small Wonders buy cost doubled added

#2 Updated by S.C. L. about 2 years ago

My personal suggestion for how to have our cake and eat it too would be either a simple ruleset switch for which improvement genera should have their buy cost doubled, or an all-out set of multipliers (one for each genus) to directly regulate buy costs.

#3 Updated by Lexxie L about 2 years ago

The Multiplayer ruleset was done a long time ago as a 'fix' or 'adjustment' for games involving large numbers of human players. It's typically being used in large map games of 50+ players. One of the fixes or workarounds it did for game play was to allow duplications of Wonders by making every Wonder a Small Wonder. Otherwise, with 50+ players, whoever gets a Wonder which is a major advantage becomes a very rare stroke of luck and advantage over all the other players.

While the 'fix' to make Small Wonders 2g/p may make a small improvement for single player and games with <12 human players, it completely breaks the game balance of the Multiplayer ruleset and the large following of people who enjoy games of 50+ players.

Game Balance is now completely off in so many ways.
1. Wonders with very large power become rather cheap to buy. Players report they don't even use Caravans and just buy them immediately, often on the turn they are available.

2. The bonus effect of the wonder compared to its low buy-off cost becomes imbalanced to where there is little strategic decision on whether to buy a Wonder. For best expert play, it now becomes obligatory to buy every Wonder like cheap candy, just to keep even with everyone else who is also buying every Wonder.

3. The noted advantage of trade-based governments (Repub., Demo.) over production-based governments (Fundamentalism, Monarchy, Communism) is wildly exaggerated. It is now that much easier for governments getting +1 trade per tile to buy off 1 prod for 2 gold, whereas production-based economies have less gold, and the use of caravans to make wonders is now at an economic ratio disadvantage to purchasing with gold. Whereas before, it was possible for a good leader to be competitive with strategies using non-trade based governments for part or most of the game, this one change forces every expert player into the same trade-based government strategies and wrecks diversity of strategic creatvity and game play.

4. 4g/prod created an efficiency ratio where it was more efficient to use Caravans to build Wonders, rather than using gold. Since it is now more efficient to use gold to buy Wonders, Caravans become not only useless units but every city continues to make its own improvements without ever bothering to plan or contribute to a Wonder, since its excess gold is enough for Wonders while it continues making its own improvements.

#4 Updated by Marko Lindqvist almost 2 years ago

  • Category changed from Rulesets to General
  • Target version set to 3.0.0

#5 Updated by Marko Lindqvist almost 2 years ago

  • Blocks Task #656466: S3_0 datafile format freeze (d3f) added

#6 Updated by Marko Lindqvist almost 2 years ago

  • Status changed from New to In Progress

This ticket is now about implementing the engine feature that allows ruleset to define how buy cost of Small Wonders is handled. Multiplayer ruleset change is split as Feature #767397

I'm working on an new effect that gives percentage change to the buy cost of a building. In addition to resolving Small Wonders case, it unhardcodes Great Wonder behavior too (and much more)

#8 Updated by Marko Lindqvist almost 2 years ago

- Renamed effect as "Building_Buy_Cost_Pct" (added "_Pct")
- Apply effect after doubling cost for prod=0 cities, for better rounding results on integer math
- Fixed typo in commit message
- Removed unused "present" column from effect requirements in rulesets

#9 Updated by Marko Lindqvist almost 2 years ago

  • Blocks Feature #767397: Double buy cost of Small Wonders in multiplayer ruleset added

#10 Updated by Jacob Nevins almost 2 years ago

We previously considered adjusting buy cost in gna bug #22089 . We came to basically the same design. We also considered letting Building_Buy_Cost_Pct=-100 act as "prevent buy", and adjusting unit buy cost too (with a separate effect, which the design here leaves room for).

#11 Updated by Marko Lindqvist almost 2 years ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

Also available in: Atom PDF