Project

General

Profile

Bug #769791

Goto handling should be after AI movement

Added by Anonymous 4 months ago. Updated about 2 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Server
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Currently player can attack AI units and escape with goto doing "double move".
That patch moves ai phase before player orders phase, so that cheat wont be posssible anymore.


Related issues

Blocks Freeciv - Task #766998: Release 2.6.1New

History

#1 Updated by Anonymous 4 months ago

  • Status changed from Resolved to Closed

#2 Updated by Marko Lindqvist 2 months ago

  • Status changed from Closed to New

As noted by bard in http://forum.freeciv.org/f/viewtopic.php?f=17&t=90702, this had unfortunate effects like making fortifying effectively taking one extra turn in single player games. Regressions caused seem worse than the problem that was solved.

#3 Updated by Marko Lindqvist 2 months ago

#4 Updated by David Fernandez (bard) about 2 months ago

Regressions caused seem worse than the problem that was solved.

I agree marko.

I like the idea of preventing this "double move" problem against the AI, and I admit that this patch makes the AI more even to humans in single player games, but the way it changes the behaviour of fortify actions, building forts, or similar actions, prevents players from using against the AI some tactics that are possible in multiplayer games.
Such changes would have a big impact on gameplay, and would force to redesign some aspects of rulesets like civ2civ3. I think this patch should not be included in a "bug fixing" release like 2.6.1.

#5 Updated by Marko Lindqvist about 2 months ago

  • Category changed from gui-qt to Server

It's more than balance issue. It's wrong that AI makes unit moves of the new turn before end of previous turn, as with currently applied patch. I have not looked closely what kind of bugs it introduces, though. I don't know if AI will move newly built units at all (or will they be finished in the end of the turn only after AI already moved), or does it get a benefit of getting to attack with units that it loses because of lack of maintenance, or does it get bonuses of previous turn's government instead of new turn's etc etc.
The correct fix would be to make cleaner separation of turn-end and turn-begin actions (goto with fresh movement points would belong to latter) and to execute AI between them.

If we can't make proper fix for 2.6.1, at least current patch should be reverted from it.

#6 Updated by Marko Lindqvist about 2 months ago

Patches to revert current implementation. I'm about to push these soon. Will leave ticket open for future implementation.

Also available in: Atom PDF