Project

General

Profile

Bug #656550

Vote bar takes up half the screen

Added by S.C. L. about 3 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
gui-gtk-3
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

As reported on the forums by user RsXT.2 (topic 75201), confirmed again for 2.6.0-beta0+r35254 gtk+3.22 client: when the vote bar is displayed, it expands to take up half the game screen.

gtk2-small-merged.png (144 KB) gtk2-small-merged.png S2_6 b221729644, gui-gtk2, small displays, "merged" layout Jacob Nevins, 2019-12-26 11:49 AM
gtk3-small-merged.png (1.34 MB) gtk3-small-merged.png S2_6 b221729644, gui-gtk3, small displays, "merged" layout Jacob Nevins, 2019-12-26 11:50 AM
gtk322-small-merged.png (1.33 MB) gtk322-small-merged.png S2_6 b221729644, gui-gtk3.22, small displays, "merged" layout Jacob Nevins, 2019-12-26 11:51 AM
gtk2-small-separate.png (198 KB) gtk2-small-separate.png S2_6 b221729644, gui-gtk2, small displays, "separate" layout Jacob Nevins, 2019-12-26 11:51 AM
gtk3-small-separate.png (1.38 MB) gtk3-small-separate.png S2_6 b221729644, gui-gtk3, small displays, "separate" layout Jacob Nevins, 2019-12-26 11:52 AM
gtk322-small-separate.png (1.21 MB) gtk322-small-separate.png S2_6 b221729644, gui-gtk3.22, small displays, "separate" layout Jacob Nevins, 2019-12-26 11:53 AM
m-gtk3-vote-bar.patch (3.94 KB) m-gtk3-vote-bar.patch Jacob Nevins, 2019-12-26 05:48 PM
30-26-gtk3-vote-bar.patch (2.83 KB) 30-26-gtk3-vote-bar.patch Jacob Nevins, 2019-12-26 05:48 PM

History

#1 Updated by Jacob Nevins about 2 years ago

  • Target version deleted (2.6.0)

Confirmed issue is still present in the 2.6.0-beta3 msys2 Gtk3.22 client under Wine, for votes once the game has started.
(As per the forum post, the window is split vertically. Using default configuration, which is "Arrange widgets for small displays" / "Merged".)

#2 Updated by Marko Lindqvist almost 2 years ago

gtk3-client also affected - just reproduced on current master with both clients.

#3 Updated by Jacob Nevins 7 months ago

I think this is specific to the "Arrange widgets for small displays" configuration (which has been the default for a lot of people).

Attached screenshots of S2_6 Gtk2, Gtk3, and Gtk3.22 with that option set (the last two look basically the same), in each of two different other configurations: "Messages and Chat reports location" = "Merged" and "Separate" respectively.

Making the Gtk3.x clients look like Gtk2, i.e. separate vote bar below the pane(s) containing the main and chat tabs, is probably the answer.

I haven't looked at code to see if it tries to do this and is just buggy, or whether it needs a rewrite.

This is the Gtk2 small-displays + "separate" layout:

+----------------------+------+
|                      |Chat| |
|                      |----+-|
|                      |      |
|----+-----------------|      |
|View|                 |      |
+----------------------+------+
|Vote 2...        [Y] [N] [A] |
+-----------------------------+

#4 Updated by Jacob Nevins 7 months ago

(With "Arrange widgets for small displays" unset, all Gtk clients behave the same: vote bar is a horizontal bar in the same pane as the Chat/Messages tabbed notebook, but above those tabs.)

#5 Updated by Jacob Nevins 7 months ago

  • Status changed from New to In Progress
  • Assignee set to Jacob Nevins

#6 Updated by Jacob Nevins 7 months ago

There's a similar bug (with similar root cause) if "Arrange widgets for small displays" is unset but "Messages and Chat reports location" = "Merged".

#7 Updated by Jacob Nevins 7 months ago

As usual, this and forthcoming patches not even compile-tested on master/gui-gtk-4.0 (but the patches applied cleanly and I did check that other usage of the relevant Gtk API functions already existed, to try to avoid reintroducing use of deprecated APIs).

#8 Updated by Marko Lindqvist 7 months ago

Jacob Nevins wrote:

As usual, this and forthcoming patches not even compile-tested on master/gui-gtk-4.0 (but the patches applied cleanly and I did check that other usage of the relevant Gtk API functions already existed, to try to avoid reintroducing use of deprecated APIs).

I tested compile with each of them against gtk+-3.94. I didn't do anything to check if they are counter-productive for the ongoing gtk+-3.94 to gtk-3.96 migration. Bug #853912 was only one with a problem.

#9 Updated by Jacob Nevins 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF