Project

General

Profile

Task #678380

Msys2-next after 170616

Added by Marko Lindqvist 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Category:
Windows Installers
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Since 170616, msys2 icu has been updated to version 59.1. Minimum Windows version for that is Windows 7, so support for Vista will be dropped on next msys2 environment version after 170616. In S2_6 the minimum Windows version is Vista, so there can be no further msys2 environment updates to that branch, unless some critical issue forces us to do so at the cost of losing Vista support.

History

#1 Updated by Marko Lindqvist 4 months ago

- Bring back 32bit builds

There's something weird with the icu version number. The dlls are still 58 though package name is 59. Either way, there's no change since msys2-170616, so the update is not bumping the requirements.

#2 Updated by Marko Lindqvist 4 months ago

  • Status changed from New to In Progress
  • Target version changed from 3.0.0 to 2.6.0-beta1

#4 Updated by Marko Lindqvist 4 months ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

#5 Updated by Marko Lindqvist 4 months ago

btw. The icu version confusion was because icu version of the build environment itself was updated to 59.1. Build target icu is still 58.2.

Also available in: Atom PDF