Project

General

Profile

Bug #681314

msys2: "Norwegian Bokmål" misdisplayed in Windows installer

Added by Jacob Nevins about 3 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Category:
Windows Installers
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

(outstanding part of Gna bug #21060)

The description of the "nb" language code (Norwegian Bokmål) is mangled on display, at least on my (Windows 7 British English) system. See screenshot. It looks to me like UTF-8 interpreted as ISO 8859-1 or Win1252.

bootstrap/langnames.txt (from which this string comes) is encoded in UTF-8. I'm guessing that encoding will pass straight through create-freeciv-gtk2-nsi.sh to the NSIS script, and what happens then will depend on NSIS' character set handling.

Is there some way to tell NSIS that the script it's been given is UTF-8 encoded, and if so will everything from then on Just Work?

Failing that, we could take the pragmatic step of changing the encoding of langnames.txt in svn to ISO 8859-1.

(Originally reported against 2.4.0-RC1. Still seen with 2.5 and 2.6 msys1-based installers, unsurprisingly.)

msys1_26_gtk3_bokmal.png (51 KB) msys1_26_gtk3_bokmal.png From Freeciv-2.6.0-beta0+6586576b2f-win32-gtk3-setup.exe, Windows 7 32-bit (British English) Jacob Nevins, 2017-07-05 11:32 PM
0016-msys2-Convert-langstat-files-to-ISO-8859-1-when-buil.patch (3.47 KB) 0016-msys2-Convert-langstat-files-to-ISO-8859-1-when-buil.patch Marko Lindqvist, 2019-12-06 10:25 PM
0001-msys2-Convert-langstat-files-to-ISO-8859-1-when-buil.patch (3.44 KB) 0001-msys2-Convert-langstat-files-to-ISO-8859-1-when-buil.patch S2_6 Marko Lindqvist, 2019-12-15 09:59 AM

History

#1 Updated by Jacob Nevins about 3 years ago

Previous comment from cazfi:

"For the UTF-8 problem this might be useful link: http://nsis.sourceforge.net/Utf8Converter"

#2 Updated by Marko Lindqvist about 3 years ago

In case it matters at all, what was the version of nsis in msys1 again? (It displays version number on the horizontal line above the "Next", "Accept" etc buttons.)

#3 Updated by Jacob Nevins about 3 years ago

WINE says that the one I took the screenshot from is "Nullsoft Install System v2.46".

#4 Updated by Marko Lindqvist almost 3 years ago

Maybe related:
"Unicode true" directive was introduced in nsis-3.0. Our msys2 installers have that directive set since gna patch #7632.

#5 Updated by Marko Lindqvist 7 months ago

The problem is present in msys2 (191012) based installer built from S3_0.

#6 Updated by Marko Lindqvist 7 months ago

Jacob Nevins wrote:

Failing that, we could take the pragmatic step of changing the encoding of langnames.txt in svn to ISO 8859-1.

Langnames.txt has other users. I'm not sure how they would like such a change.

#7 Updated by Marko Lindqvist 7 months ago

Here's a patch to do installer build time conversion of the language statistics I will test when I get the opportunity. This testpatch is for S3_0 msys2 installers.

#8 Updated by Marko Lindqvist 7 months ago

  • Status changed from New to In Progress
  • Target version set to 2.6.2

Marko Lindqvist wrote:

Here's a patch to do installer build time conversion of the language statistics I will test when I get the opportunity.

Seems to work.

#9 Updated by Marko Lindqvist 7 months ago

  • Subject changed from "Norwegian Bokmål" misdisplayed in Windows installer to msys2: "Norwegian Bokmål" misdisplayed in Windows installer
  • Status changed from In Progress to Resolved
  • Target version changed from 2.6.2 to 2.6.1

Splitting to two tickets, one for msys1 and one for msys2. This is mainly because fixes may land in different releases. As this ticket already has msys2 patch, making Bug #852637 the msys1 one.

It's not clear if this patch can make it to 2.6.1 release or not, but working towards it.

#11 Updated by Marko Lindqvist 7 months ago

  • Target version changed from 2.6.1 to 2.6.2

#12 Updated by Marko Lindqvist 7 months ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

Also available in: Atom PDF