Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #683570

Lua server.play_music() loops its track forever

Added by Jacob Nevins over 4 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Category:
Client
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

The Lua function server.play_music() was added in gna patch #5439 . It's described on the forum as "After the lua-initiated track has been played, regular music continues."

However, when I try it, it seems to loop the selected track forever; it only returns to style music when the style changes. The forum post suggests that that wasn't the intended behaviour.

It doesn't look like anything can call audio_play_music_tag() with repeat==FALSE, which may be relevant.

History

#1 Updated by Jacob Nevins over 3 years ago

  • Sprint/Milestone changed from 2.6.0 to 2.6.1

#2 Updated by Jacob Nevins almost 2 years ago

  • Sprint/Milestone changed from 2.6.1 to 2.6.2

#3 Updated by Jacob Nevins over 1 year ago

  • Sprint/Milestone changed from 2.6.2 to 2.6.3

#4 Updated by Marko Lindqvist 10 months ago

  • Category set to Client
  • Status changed from New to In Progress
  • Sprint/Milestone changed from 2.6.3 to 2.6.4

Jacob Nevins wrote:

It doesn't look like anything can call audio_play_music_tag() with repeat==FALSE, which may be relevant.

That's not the problem. For unrelated reasons music should always have 'repeat' on (that's not too clean design, but let's not go there in this ticket). The problem is that once MU_SINGLE music plays, the music finished callback never (not even when the single track itself finishes) selects a new track.

#7 Updated by Marko Lindqvist 10 months ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

Also available in: Atom PDF