Project

General

Profile

Bug #685252

Achievement literate obtained in wrong situations

Added by David Fernandez (bard) 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
General
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

I have noticed that the literate achievement, available in civ2civ3 ruleset, it is often obtained earlier than it is supposed.

[achievement_literate]
name           = _("Literate")
type           = "Literate" 
unique         = FALSE
value          = 100

With this code I'd expect the achievement to be obtained when every city owns a library, doesn't it?
In my latest game I got the 100% literacy message when I built my 2nd library in a civilization with more than 10 cities.

I was using a custom ruleset, but I'm trying to catch a savegame using the official ruleset. I'll upload it when ready, I just wanted to verify first if 100% literacy means what I think it means.

History

#1 Updated by David Fernandez (bard) 4 months ago

It seems literate value doesn't mean what I thought. I thought the literacy concept shown in the demographic report was linked to the literate achievement, and it looked buggy, but if they have no relation then probably there is no bug, sorry.

I upload a savegame (for S2_6 with civ2civ3) where dutchs got the achievement "literate" the turn they researched Literacy tech, even without any library built, just in case this was not the expected behaviour.

If this behaviour is right, and I see it ok (just unexpected), then this ticket could be reused to fix the related message of civ2civ3 ruleset: "You have achieved 100% of literacy", and to name it something different than the demographic report to avoid missunderstandings like mine. I'd thank suggestions.
"your civilization becomes literate"?
"your civilization is the first one to become literate"?

#2 Updated by Marko Lindqvist 4 months ago

From README.achievements:
Literate
Achievement is granted when player's literacy score is at least
<value>.

It's the overall score value, not literature percentage. The relation between the two is basically that score is not divided by population points (you get higher score with 5 literate people out of 10 total than 3 out of 4 total, though percentage would be only 50% against 75%)

#3 Updated by David Fernandez (bard) 4 months ago

Ah, ok, thanks. then I'll test to change the value of the achievement too.

That text in the readme was what led me to believe that value of literate was linked to value of literacy (as shown in demographic report, since there is no other reference to literacy score in the docs or the UI, that I know).

Could you change the title of the ticket to something like "civ2civ3: readjust value and message of literate achievement".

#4 Updated by Marko Lindqvist 4 months ago

  • Target version set to 2.6.0-beta1

Thinking about it, intention probably was to have teh achievement to depend on literacy percentage. It was meant as a way to benefit someone who builds up their literacy level, but as it's now, it's another thing you can achieve by getting your empire large enough. I'm inclined to change the implementation.

#6 Updated by David Fernandez (bard) 4 months ago

Marko Lindqvist wrote:

Thinking about it, intention probably was to have teh achievement to depend on literacy percentage. It was meant as a way to benefit someone who builds up their literacy level, but as it's now, it's another thing you can achieve by getting your empire large enough. I'm inclined to change the implementation.

I agree. I'll test the patch.

#7 Updated by Marko Lindqvist 3 months ago

David Fernandez (bard) wrote:

I'll test the patch.

Any progress?

#8 Updated by David Fernandez (bard) 3 months ago

Marko Lindqvist wrote:

Any progress?

I made one test with patched S2_6 and civ2civ3 rules, but I think something is not working right.
I have a game with 5 cities, all them with libraries and universities. The turn where the last university is built, the demographic report reaches 100% literacy, but I do not get the literate achievement (value set to 100, and I tested 99 too, just in case).

However, if I save the game and I reload it, the achievement does appear.

I have to go now, I'll test it again later today.

#9 Updated by David Fernandez (bard) 3 months ago

Another test, this time I get the achievement one turn before I expected, when the demographic report was showing 68% literacy (2 cities with 2 libraries and 1 university), and next turn I was going to finish the 2nd university to reach 100% literacy.

I upload a savegame (S2_6 + your patch). Press end turn twice to get the achievement.

#10 Updated by Marko Lindqvist 3 months ago

David Fernandez (bard) wrote:

Another test, this time I get the achievement one turn before I expected, when the demographic report was showing 68% literacy (2 cities with 2 libraries and 1 university), and next turn I was going to finish the 2nd university to reach 100% literacy.

I upload a savegame (S2_6 + your patch). Press end turn twice to get the achievement.

I get the behavior you describe from this savegame without the patch. With the patch the achievement is gained the next turn change after demographics first shows 100% literacy, consistent with your earlier test. It's unfortunate that the achievement is not gained before player can check demographics to see 100% there, but that's just because of the order of the things in turn change (achievement is gained in the end of the turn based on literacy score of that turn, while literacy score to show at demographics updates after the turn change, for the new turn) To do anything about that is outside the scope of this ticket (let's open a new ticket about that)

#11 Updated by Marko Lindqvist 3 months ago

Marko Lindqvist wrote:

To do anything about that is outside the scope of this ticket (let's open a new ticket about that)

-> feature #693946

#12 Updated by Marko Lindqvist 3 months ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

#13 Updated by David Fernandez (bard) 3 months ago

You are right. It seems I did not patch it right for my 2nd test, sorry.
I have tested again the savegame and the achievement is properly gained the turn after I reach 100% literacy.

Also available in: Atom PDF