Project

General

Profile

Bug #692096

Darwin's Voyage doesn't give two technology advances in multiplayer ruleset

Added by Andreas Røsdal 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Rulesets
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Darwin's Voyage doesn't give two technology advances in the multiplayer ruleset.

This has been tested and verified that Darwin's Voyage doesn't work in both on the latest Github version of the desktop version of Freeciv, and not working in the LongTurn games on Freeciv-web in production running almost the latest GitHub version of the Freeciv C server (where this bug was first reported by a player).

However, Darwin's Voyage does work correctly in Freeciv version 2.5.9, where it gives two advances.

This can be tested by specifying the multiplayer rulesetdir, setting techlevel 60, then building Darwin's Voyage, and observing if two advances are given when Darwin's Voyage is completed.

25_multi_darwin.sav.bz2 (15.6 KB) 25_multi_darwin.sav.bz2 S2_5 savegame; "end turn" to build Darwin's Voyage Jacob Nevins, 2017-08-21 08:13 PM
m-30-26-multiplayer-darwin-fix.patch (1.1 KB) m-30-26-multiplayer-darwin-fix.patch Jacob Nevins, 2017-08-21 08:39 PM

History

#1 Updated by Andreas Røsdal 3 months ago

  • Tracker changed from Task to Bug

#2 Updated by Jacob Nevins 3 months ago

S2_6+ give this error for me:

lua error:
    [string "tolua: embedded Lua code"]:79: error in function 'give_tech'.
     argument #4 is 'string'; 'boolean' expected.

stack traceback:
    : in field 'give_tech'
    [string "tolua: embedded Lua code"]:79: in method 'give_tech'
    data/multiplayer/script.lua:40: in function 'building_built_handler'

#3 Updated by Jacob Nevins 3 months ago

  • Status changed from New to In Progress
  • Assignee set to Jacob Nevins

An edit was missed during gna patch #6531 .

Fix is in ruleset (data/multiplayer/script.lua), so should be easy to deploy.

Anyone who missed out on techs due to this won't get "Theory of Evolution" either (the pseudo-tech that prevents multiple bonuses from rebuilding), so if they were to rebuild Darwin's Voyage after the fix is deployed, they'd get the techs the second time round.

#4 Updated by Jacob Nevins 3 months ago

Fix verified on all relevant branches, and verified on S2_6 that building Darwin's Voyage a second time doesn't get you extra techs.

#5 Updated by ᳇ Ϻ⚸Яℨ⚔ ᳇ 3 months ago

It shouldn't be fixed that way, darwin is game breaker, few nations can research stealth very fast after railroad. Either it should be great wonder or it should just give one time extra 1000 bulbs.

#6 Updated by Jacob Nevins 3 months ago

Created feature #692110 to discuss whether it's overpowered. I intend to submit the patch as submitted, to fix the regression from 2.5.

#7 Updated by Jacob Nevins 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF