Project

General

Profile

Feature #693269

Enable client heartbeat by default

Added by Jacob Nevins 3 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Client
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Gna bug #19561 (debuting in 2.6) added an option client ping to the server, to help diagnose the case where there was/is a connection outage, the server has cut the connection due to ping timeout, and the player is waiting for something to appear in the client (such as turn change or game start).

It's currently disabled by default. Perhaps it would be more useful if it were enabled.

Pros:
  • The people most likely to be helped by this diagnostic are those least likely to find the option and turn it on.
  • The server is always pinging the client, so unlike a tool like PuTTY (which has keepalives off by default), there's no chance in this case of a connection otherwise surviving a connection loss of a few minutes or more.
    Cons:
  • Risk of regression from new feature (that's why it's off by default).
  • Bit more network traffic even for non-idle clients?

History

#1 Updated by Marko Lindqvist 2 months ago

  • Target version changed from 2.6.0 to 2.6.0-beta2

#2 Updated by Jacob Nevins 2 months ago

I intend to enable this in beta1, otherwise anyone who installs that will get the default in their rc-file and not exercise it.
I would rather know early, if it's going to cause trouble.

For what it's worth, I have been running with it enabled locally since I raised this ticket, and nothing has exploded yet.

#3 Updated by Jacob Nevins 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF