Project

General

Profile

Bug #694328

Game/civilization info box popup has no background (gtk3.22)

Added by S.C. L. (Caedo) 24 days ago. Updated 2 days ago.

Status:
In Progress
Priority:
Normal
Assignee:
Category:
gui-gtk-3
Target version:
Start date:
Due date:
% Done:

0%


Description

The extended info box that pops up when clicking on the text above the "Turn done" button is drawn without a background, making the text hard to read (especially since there is other text behind it).

Discovered in Freeciv-2.6.0-beta0+c8cad4d8dd-msys2-win64-gtk3.22 on Windows 10 Home v1703 x64

This is Freeciv version 2.6.0-beta0-msys2 (beta version), gui-gtk-3.22 client.
Built against gtk+ 3.22.16, using 3.22.16
Built against glib 2.52.3, using 2.52.3

Probably strongly related to issue #656549

26-gtk3-info-popup.patch View - S2_6 (1.43 KB) Jacob Nevins, 2017-09-02 09:37 AM

History

#1 Updated by Jacob Nevins 22 days ago

So:
  • bug #656549 was like this for the middle-click map popup
  • removing gtk_widget_set_app_paintable() fixed that
  • show_info_popup() is the only other instance of gtk_widget_set_app_paintable() in the Gtk3/3.22 clients
    • I think this is the one you're referring to? Clicked text starts "Population: 10,000 ..." and popup starts "10,000 People ..."

Which suggests a fairly simple fix.
Attached a patch for S2_6; since I think my Gtk3 is too old to demonstrate the issue, I can't verify it resolves it, but it has no obvious ill effects for me. (And I haven't tested Gtk3.22 at all.)
If someone who can verify the fix wants to take over this ticket, feel free, otherwise I can commit it if someone verifies it actually helps.

#2 Updated by Marko Lindqvist 22 days ago

Jacob Nevins wrote:

So:
  • bug #656549 was like this for the middle-click map popup

Attached a patch for S2_6; since I think my Gtk3 is too old to demonstrate the issue

At least bug #656549 was visible with Windows backend only.

#3 Updated by Marko Lindqvist 16 days ago

Jacob Nevins wrote:

I can commit it if someone verifies it actually helps.

Clearly the windows should not be set app_paintable, so maybe commit the patch in any case. Just leave this ticket open until it's confirmed with some build that it fixed this particular bug.

#4 Updated by Jacob Nevins 16 days ago

  • Category changed from gui-gtk-3.22 to gui-gtk-3
  • Status changed from In Progress to Closed
  • Assignee set to Jacob Nevins

Patch applies as-is to S3_0 and trunk (it turns out these calls were already removed from gui-gtk-4.0 by feature #637944), so applied.

#5 Updated by Jacob Nevins 16 days ago

  • Status changed from Closed to In Progress

#6 Updated by Jacob Nevins 15 days ago

  • Target version changed from 2.6.0 to 2.5.10

...why didn't I commit this to S2_5 too, like the previous similar fix? Now done.

#7 Updated by Marko Lindqvist 2 days ago

Marko Lindqvist wrote:

Just leave this ticket open until it's confirmed with some build that it fixed this particular bug.

...like 2.6.0-beta1 msys2 gtk3.22-client build.

#8 Updated by S.C. L. (Caedo) 2 days ago

Marko Lindqvist wrote:

Marko Lindqvist wrote:

Just leave this ticket open until it's confirmed with some build that it fixed this particular bug.

...like 2.6.0-beta1 msys2 gtk3.22-client build.

This is fixed now. Great job!

Also available in: Atom PDF