Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Feature #694778

AI regressions when switching from classic to civ2civ3 ruleset

Added by Marko Lindqvist almost 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
AI
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Some AI problems come up more prominently with civ2civ3 ruleset than with classic ruleset. Some of those are serious enough to be consider blockers of releasing freeciv-3.0 with civ2civ3 as default ruleset. This ticket is for collecting those cases, and following the development.

The ideal solution for these problems would be making AI to behave, but since the problems typically are very hard to solve, in some cases we may need to adjust the civ2civ3 ruleset. If we can't make AI behavior acceptable for civ2civ3 as default ruleset even then, as last resort we have to revert back to classic ruleset as default ruleset.

freeciv-T0167-Y01160-auto.sav.xz (104 KB) freeciv-T0167-Y01160-auto.sav.xz Chippo Elder, 2020-01-18 09:29 PM
freeciv-T0081-Y-0500-auto.sav.xz (76.6 KB) freeciv-T0081-Y-0500-auto.sav.xz Chippo Elder, 2020-01-19 11:25 AM
taxed-out.sav.bz2 (277 KB) taxed-out.sav.bz2 Chippo Elder, 2020-02-04 03:28 PM
overtaxed.sav.bz2 (161 KB) overtaxed.sav.bz2 Chippo Elder, 2020-02-05 08:35 PM

Related issues

Blocked by Freeciv - Bug #696007: AI can't handle (military) units with gold upkeepClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Blocked by Freeciv - Bug #855339: AI doesn't do anything to actually win (civ2civ3)Closed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by David Fernandez (bard) almost 5 years ago

I'm interested to know the main AI regressions that you noticed with civ2civ3 rules, and possible suggestions to improve the AI behaviour by changing the ruleset.
I agree that civ2civ3 should not be the default rules if the AI is clearly inferior than with classic rules.

#2 Updated by Jacob Nevins almost 5 years ago

I've got a S2_6 civ2civ3 autogame I ran recently; I intend to upload selected details to a new ticket for people to pick over.

One continuing theme is AI getting stuck on 100% tax and making no progress in science for thousands of years. (Admittedly I haven't run a classic-ruleset autogame to compare, I should do that.)

#3 Updated by Marko Lindqvist almost 5 years ago

  • Blocked by Bug #696007: AI can't handle (military) units with gold upkeep added

#4 Updated by David Fernandez (bard) almost 5 years ago

I suspect that AI does not take into account food upkeep either.
In civ2civ3, if the population of a city is lower than the number of units supported by the city, the extra units have to pay upkeep of food. I thought this would limit the units built by the AIs, but they seem to continue building units even at starving cities that can not support new units.

I have also noticed that AI does not seem to take into account the penalties due to tired attack. In my latest games, the AI tend to attack my units in situations where the odds are clearly against the AI, but would be favourable to AI without the tired attack. I was waiting for confirmation before opening a new ticket.

#5 Updated by Jacob Nevins over 2 years ago

  • Blocked by Bug #855339: AI doesn't do anything to actually win (civ2civ3) added

#6 Updated by Jacob Nevins over 2 years ago

In 2017 I wrote:

One continuing theme is AI getting stuck on 100% tax and making no progress in science for thousands of years.

Is this still a thing? I thought it was, but I'm not finding much written down about it, either in HRM or Gna...
I've got a bit set that I once thought it was something to do with gold_upkeep_style, but not finding much evidence of that either.
Is all of this out of date? I suppose I should run a civ2civ3 autogame to find out whether AIs still get stuck at 100% tax.

#7 Updated by Chippo Elder over 2 years ago

Oh yes, this still happens with civ2civ3 ruleset and 3.0.0-alpha3+ (modified 887c896696).

I didn't realize it was a bug - I thought they were doing something intelligent with their money.

In the attached savegame, I have embassies with all 14 other players, and I can see that only the Cypriots and the Occitans are not at 100% tax.

#8 Updated by Chippo Elder over 2 years ago

And it happens in master (3.0.92-dev (4d978134d0)).

Attached is a savegame where I have 10 embassies and I can see that 8/10 of the AIs are stuck on 100% tax.

#9 Updated by Chippo Elder over 2 years ago

It happens in sandbox also!

In the attached savegame (2.6.1+), there are 11 AIs and all of them are on 100% tax.

I suspect (with low confidence) that:
  • it doesn't happen in classic
  • it happens with all descendants of civ2civ3
  • if the human player plays tech-broker, then it happens faster than if she doesn't

I've done a lot of whining about civ2civ3 recently because I'm 'looking' for bugs and faults. I love civ2civ3. This bug is the biggest impediment, by far, IMNSHO, for civ2civ3 becoming the default ruleset.

#10 Updated by Chippo Elder over 2 years ago

And it happens in experimental too!

Here's a savegame (2.6.1+) where I've just - this turn - received Marco Polo's and can see all the AI's Tax Rates. You'll notice that the AIs I've know for more than just-this-turn are almost all at 100% tax. And that supports my 3rd suspicion above.

However, look through the AIs that I haven't yet had a chance to pollute with my western market philosophies. Most of them are already stuck on 100% tax. This tells me that my tech-brokerage has got nothing to do with it at all.

And while my 1st suspicion might still be true, isn't experimental a descendant of classic, rather than civ2civ3?

What does/do experimental, sandbox and civ2civ3 all have in common, that classic does not have?

#11 Updated by Marko Lindqvist about 1 year ago

  • Category set to AI
  • Status changed from New to Closed

Chippo Elder wrote:

What does/do experimental, sandbox and civ2civ3 all have in common, that classic does not have?

Units have gold upkeep.

This discussion has now moved to osdn -> https://osdn.net/projects/freeciv/ticket/42191
Closing ticket here in hrm.

Also available in: Atom PDF