Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #707576

The last two "now valid" SVG flags from the list of the worst cases (aa-log.txt)

Added by frank e over 3 years ago. Updated over 3 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Nations
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

liberia.svg was GNAPATCH#7479

west papua.svg was GNAPATCH#7394

Valid PD SVG flags from Wikimedia Commons, any credits saying something else about the invalid old flags are not more applicable. Both need new PNGs (flag + flag large + shield + shield large), because the newer valid SVGs are visually different.


Related issues

Related to Freeciv - Bug #706407: Various "now valid" SVGs (colours + credits + flags + shields unmodified)New

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by frank e over 3 years ago

  • Related to Bug #706407: Various "now valid" SVGs (colours + credits + flags + shields unmodified) added

#2 Updated by frank e over 3 years ago

Cf. Nations maintainer on the forum.

#4 Updated by Marko Lindqvist over 3 years ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

#5 Updated by Daniel Markstedt over 3 years ago

For the record: The new Liberian flag committed in this ticket isn't 2:3 aspect ratio but rather 10:19. This renders into a 29x16px small flag bitmap image, which is inconsistent with the 29x20 px flag images that all the other 2:3 svg images are producing. I would recommend resizing the image for a more consistent look in-game.

The Papuan flag is still 2:3!

#6 Updated by frank e over 3 years ago

Daniel Markstedt wrote:

The new Liberian flag committed in this ticket isn't 2:3

SVGs from commons use the official aspect ratio and colors, and not all flags are 2:3. For Liberia exactly the same procedure as for USA should work:

Use rsvg-convert without scaling (because rsvg-convert can scale, but the results suck) to get some big PNG, then add (=copy) or substract (=crop) pixels either at the top/bottom or left/right side to get a big 2:3 PNG, then use decent scaling tools like imagew to get the wanted PNG flags, and finally use the existing masking PNGs for the wanted shield sizes.

I don't know why, but it's not simply 2:3, it's 44x30 (instead of 45x30) for big flags or 29x20 (instead of 30x20) for small flags. For my manual recipe check out the Nations/recipe sub-page on the Wiki.

#7 Updated by Marko Lindqvist over 3 years ago

  • Status changed from Closed to New
  • Assignee deleted (Marko Lindqvist)

Reopening for handling the Liberian flag aspect ratio.

#8 Updated by Jacob Nevins over 3 years ago

  • Sprint/Milestone deleted (2.6.0-beta2)

#9 Updated by Jacob Nevins over 3 years ago

Reopening for handling the Liberian flag aspect ratio.

Rats, didn't get around to this, but I don't want a regression in 2.6.0-beta2.

I intend to revert commit:2720a21e11 (S2_6) and other branch equivalents. I intend to do this before beta2 release tomorrow, even though it's only a few hours away.

For Liberia exactly the same procedure as for USA should work: [...]

This loses the property that the PNGs are automatically derived from the SVG. I'd prefer that the SVG is modified for our requirements relative to Commons.

#10 Updated by Daniel Markstedt over 3 years ago

For Liberia exactly the same procedure as for USA should work: [...]

This loses the property that the PNGs are automatically derived from the SVG. I'd prefer that the SVG is modified for our requirements relative to Commons.

I agree with Jacob here. There is an inherent value in having a fully automated procedure. For instance, when you want to generate an entire new flagset for, say, a very large or very small tileset.

Also available in: Atom PDF