Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #763885

If player gets unique=false achievement first, bonus culture added twice

Added by Akechi . over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
General
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

I checked at 2.6.0-RC1.

From http://freeciv.wikia.com/wiki/Forum:Some_tiny_issues (13):

In Freeciv 2.6.0 beta r34796, when player gets unique=false achievement first, bonus culture added twice.
e.g. in civ2civ3, if you are first player to found foreign continent, you get 200 culture. (instead of 100)
Sorry if this is not a bug. (it seems fastest achievement bonus!)

(common\achievements.c achievement_plr)


Related issues

Blocks Freeciv - Task #656706: Handle http://freeciv.wikia.com/wiki/Forum:Some_tiny_issuesNew

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Jacob Nevins over 2 years ago

It wasn't explicitly stated in gna patch #4906, where this was added, whether the intention was to give the first achiever double the culture points. Ruleset comments don't mention it either.

#2 Updated by Jacob Nevins over 2 years ago

cazfi, what was your original intention here, do you know?

#3 Updated by Jacob Nevins over 2 years ago

  • Sprint/Milestone changed from 2.6.0 to 2.6.1

#4 Updated by David Fernandez (bard) over 2 years ago

At least in civ2civ3, I think this was the desired behaviour, this way there is some extra bonus for the fastest player, as you said.

#5 Updated by Marko Lindqvist over 2 years ago

When achievement has no unique flag, it should not treat first gainer special.

It's possible to get extra bonus for first gainer in the ruleset by defining two similar achievements, of which one is unique and the other is not.

#6 Updated by Jacob Nevins over 2 years ago

  • Blocks Task #656706: Handle http://freeciv.wikia.com/wiki/Forum:Some_tiny_issues added

#8 Updated by Marko Lindqvist over 2 years ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

Also available in: Atom PDF