Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #764965

"Wonder will be finished " notice is displayed even if it's already obsolete

Added by fomalhaut pa over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

2.6.0-RC1

Notice: Wonder %s in %s will be finished next turn.
This message is unnecessary if Wonder under construction become obsolete.

m-30-26-wonder-notice-suppress-obsolete.patch (1.2 KB) m-30-26-wonder-notice-suppress-obsolete.patch Jacob Nevins, 2018-07-14 11:15 PM
26c2c3_building_obsolete_wonder.sav.bz2 (14.6 KB) 26c2c3_building_obsolete_wonder.sav.bz2 savegame for testing this Jacob Nevins, 2018-07-14 11:16 PM

History

#1 Updated by Jacob Nevins over 2 years ago

I think this is a regression since 2.5, that came in with gna patch #3941.

I don't know why city_global_turn_notify() was changed in the way it was. I've changed it to what I think it should always have been, and it fixes this problem in my testing.

#2 Updated by Jacob Nevins over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF