Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #765938

"Spy is not an attack unit" after bribing unit in stack

Added by Jacob Nevins over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Server
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

In the experimental ruleset, it's possible to bribe a unit in a stack.

The message log after I successfully do so with a Spy in 2.6.0ish:

Your Spy succeeded in bribing the Warriors.
Moved your Warriors.
Spy is not an attack unit.

I assume the last is rom some fall-through to regular attack handling?

0001.patch (1.88 KB) 0001.patch Sveinung Kvilhaugsvik, 2019-12-18 07:50 PM
2.6-bug-765938.patch (2.83 KB) 2.6-bug-765938.patch Sveinung Kvilhaugsvik, 2019-12-21 10:45 PM
3.0-bug-765938.patch (2.84 KB) 3.0-bug-765938.patch Sveinung Kvilhaugsvik, 2019-12-21 10:45 PM
3.1-bug-765938.patch (2.87 KB) 3.1-bug-765938.patch Sveinung Kvilhaugsvik, 2019-12-21 10:46 PM
0001-Don-t-attempt-to-move-to-bounced-unit-s-tile.patch (2.87 KB) 0001-Don-t-attempt-to-move-to-bounced-unit-s-tile.patch Sveinung Kvilhaugsvik, 2019-12-25 01:30 AM

History

#1 Updated by Jacob Nevins about 1 year ago

  • Sprint/Milestone changed from 2.6.1 to 2.6.2

#2 Updated by Sveinung Kvilhaugsvik about 1 year ago

  • Category set to Server
  • Status changed from New to In Progress
  • Assignee set to Sveinung Kvilhaugsvik

The problem is that the briber tries a post bribe move the the target unit's tile since it only contains one unit. It assumes that that one unit must be its target. But if the tile contained two units the target unit will get bounced.

#3 Updated by Sveinung Kvilhaugsvik about 1 year ago

Untested patch. Probably 3.1 only (patch context).

#5 Updated by Marko Lindqvist about 1 year ago

It seems this was already pushed to master and S3_0, but not to S2_6?

#6 Updated by Sveinung Kvilhaugsvik about 1 year ago

Marko Lindqvist wrote:

It seems this was already pushed to master and S3_0, but not to S2_6?

Correct. Just a matter of logistics. I need to apply it to current 2.6, build and test.

#7 Updated by Sveinung Kvilhaugsvik about 1 year ago

The 2.6 version with the same commit message as the others. Is is now tested against current S2_6. Removing assignee in case someone else wishes to committ it before I get around to fixing my logistics problems.

#8 Updated by Sveinung Kvilhaugsvik about 1 year ago

  • Status changed from Resolved to Closed
  • Assignee set to Sveinung Kvilhaugsvik

Also available in: Atom PDF