Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #778016

Qt client hangs when load game pressed with no selected game

Added by David Fernandez (bard) over 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
gui-qt
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

I'm testing v2.6.
In qt main menu, when I press "Load saved game", no game is selected by default. If then I press "Load" button (without selecting manually any game), the client gets hang showing a "Loading..." screen.

I think it should not try to load unless some game is selected, or it should select some game by default.

Else, I sometimes forget to select a game when I press load, and it takes me several minutes to realize that is not really loading anything.

History

#1 Updated by Marko Lindqvist over 1 year ago

The patch does not apply to S2_5. I may still check that, but at least S2_6 and later branches should be committed already so it makes it to 2.6.1 release (and testing before that).

#2 Updated by Marko Lindqvist over 1 year ago

The problem is not so severe in S2_5. There it goes to pregame page, from which user can exit (disconnect from server) back to main menu. Also, there's chat window that shows the error message server has sent.

#3 Updated by Marko Lindqvist over 1 year ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

Also available in: Atom PDF