Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Feature #821415

Advise users if their firmware is the latest and/or requires updating

Added by Luigi Di Fraia over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Estimated time:

Description

Suggestion from the disk transfer team, to improve handling firmware:

It would be nice when pressing "Read firmware" it would write a detailed message
a) You have the newest firmware
b) Newer firmware version exists - but not required
c) Newer firmware version exists - and IS required (possible also disable all functionality until update done)

The messages on the screen could be;
a) Firmware fully update (version 2.2.1.0.0)
b) Firmware can be updated from v. 2.2.1.0.0 to 2.2.2.0.0 (not required)
c) Firmware must be updated from v.2.2.1.0.0 to 2.3.0.0.0 (required)

History

#1 Updated by Luigi Di Fraia over 1 year ago

  • Sprint/Milestone changed from v3.9 to v3.8.1

#2 Updated by Luigi Di Fraia over 1 year ago

  • Description updated (diff)
  • Status changed from New to Closed
  • % Done changed from 0 to 100

Implemented with the caveat that no distinction is made if an update in not strictly required. The other difference is that a client can also suggest a downgrade, which is the best thing to do if users don't have Internet access to download an updated version of the client software.

Also available in: Atom PDF