Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #846106

Sharing maps does not completely update recipient's knowledge

Added by Zoltán Žarkov over 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Category:
Server
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Players have reported that after sharing maps, city sizes, borders etc are not current. I will post repro cases and more details once this game is no longer sensitive.

History

#1 Updated by Marko Lindqvist 12 months ago

Zoltán Žarkov wrote:

once this game is no longer sensitive.

Any ETA?

#2 Updated by Zoltán Žarkov 11 months ago

Repro is pretty simple, but attached a save anyway. Have Sweden share maps to Japan and you will see the border information around Stockholm not being visible to Japan.

Root cause is that Sweden's plrtile->owner for these tiles is NULL, so in really_give_tile_info_from_player_to_player it does not think it has to do anything.

As to why plrtile->owner is NULL, it should be because update_player_tile_knowledge never sets it. I don't understand the intended reasoning of plrtile_owner_valid introduced in https://github.com/freeciv/freeciv/commit/a1253202de3649403130364e87c27613aba9d92b

bool plrtile_owner_valid = game.server.foggedborders && !map_is_known_and_seen(ptile, pplayer, V_MAIN);

#3 Updated by Zoltán Žarkov 11 months ago

  • Assignee set to Zoltán Žarkov

#4 Updated by Zoltán Žarkov 11 months ago

Since plrtile->owner was being set to the tile's current owner only when foggedborders enabled and the player does not have vision, it seemed low risk to always set it correctly here. This is safer if foggedborders gets enabled midgame as some comments warn. This fixes the map sharing, because now the map giver with live vision of the tile has a correct plrtile->owner when it was always NULL previously. I might be missing some other nuance of this function though.

#5 Updated by Marko Lindqvist 11 months ago

Target version has been set to 3.0.0. Isn't S2_6 affected?

#6 Updated by Zoltán Žarkov 11 months ago

The S2_6 logic here was identical but needed a different patch

#7 Updated by Marko Lindqvist 11 months ago

  • Status changed from New to Resolved
  • Assignee changed from Zoltán Žarkov to Marko Lindqvist

#8 Updated by Marko Lindqvist 11 months ago

  • Category set to Server
  • Status changed from Resolved to Closed

#9 Updated by Lexxie L 11 months ago

Author has filed a complaint that this is not open source code. FCW has been operating under the assumption that this is an open source project and all code on HRM and master branch are submitted to be part of an open source license. Please provide clarity on what code in master branch is not open source, thanks.

#10 Updated by Sveinung Kvilhaugsvik 11 months ago

Lexxie L wrote:

Author has filed a complaint that this is not open source code.

Do you have a link to this complaint? Did he claim that this isn't licensed under the GPL? Did he mention what license he had to distribute the derived work (his code + Freeciv) at all if not under the GPL?

#11 Updated by Lexxie L 11 months ago

It's on Discord. I can provide all of it, but this place is likely not a good spot to feed this author's drama? Since we took some changes to maphand.c from github master, not even knowing who did it, he came back with these exact quotes:

"I notice you are redistributing some of my copyrighted work." "Stop redistributing any of my work" "I just ask that you remove my work from your repo."

FCW believes freeciv master to be an open source project and only because of this belief, submits ideas for features, and/or implements other code we find here. Besides features authored from us, we have not sourced anything from anywhere else. This request to remove code we obtain from master because it's not open source and not GPL, creates lots of needless drama and there should be some implied consent. The comments at the top of the maphand.c file specifically state GPL so this legally qualifies as implied consent.

I'm sorry to report this individual has a long history of this kind of behaviour and a simple statement to him about acceptable/unacceptable and what are rules and consents, probably needs to happen. Also I did not actually get an answer to the question though. FCW needs to know what parts of the master branch are not GPL so it knows how to process this. Thanks.

#12 Updated by Sveinung Kvilhaugsvik 11 months ago

Also I did not actually get an answer to the question though.

I'm not aware of any files in master that aren't under a Free Software license. I would describe Freeciv's development methodology as Open Source.

#13 Updated by Lexxie L 11 months ago

It might be a good time to clarify this one with all individuals that if they submit here it's GPL, some kind of official consent so we can end this kind of NONSENSE would be very appreciated !

#14 Updated by Marko Lindqvist 11 months ago

Freeciv is licensed under GLPv2+
Contributions to freeciv are made under GPLv2+
Contributor retains the copyright

#15 Updated by Jacob Nevins 11 months ago

By receiving a copy of GPL-licensed software, you can be sure that no-one is going to later revoke your right to distribute and modify the software. Any recipient of Freeciv code can choose to use GPLv3 terms ("you can redistribute it and/or modify it under the terms of the [GPL]; either version 2, or (at your option) any later version") which is very clear that copyright holders cannot later revoke the licence they granted ("All rights granted under this License are granted for the term of copyright on the Program, and are irrevocable provided the stated conditions are met"); and there are plenty of arguments for GPLv2 as well.

Also available in: Atom PDF