Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #847413

Visibility of units loading without moving is not updated

Added by Alexandro Ignatiev over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Server
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

If a unit loads on a ship on another tile, it disappears from sight of non-allied players seeing either tile. If it loads into a trireme standing on a river on the same tile, the trireme is updated for the clients (gets "+") but the cargo does not go out of sight.

Remark: for future versions I am making a patch for an option for seeing fortified units in triremes, it covers this problem.


Related issues

Is duplicate of Freeciv - Bug #858214: Ghost units seen, packhand assertion failure (2.6.1+, various clients)Closed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Jacob Nevins over 1 year ago

  • Sprint/Milestone changed from 2.6.1 to 2.6.2

#2 Updated by Jacob Nevins about 1 year ago

Sounds like it's the same as the later bug #858214 (recently fixed)?

#3 Updated by Jacob Nevins about 1 year ago

  • Related to Bug #858214: Ghost units seen, packhand assertion failure (2.6.1+, various clients) added

#4 Updated by Jacob Nevins about 1 year ago

  • Status changed from New to Closed

No-one's commented, so I'm closing this one as a duplicate of #858214 (raised later, but has the actual fix attached), since it sounds like it describes the exact same situation.

Shout if you think that is wrong.

#5 Updated by Jacob Nevins about 1 year ago

  • Related to deleted (Bug #858214: Ghost units seen, packhand assertion failure (2.6.1+, various clients))

#6 Updated by Jacob Nevins about 1 year ago

  • Is duplicate of Bug #858214: Ghost units seen, packhand assertion failure (2.6.1+, various clients) added

Also available in: Atom PDF