Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #852070

Formatting error in man page about freeciv-gtk3.22

Added by Jacob Nevins about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Documentation
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

The freeciv-client(6) man page section about freeciv-gtk3.22 doesn't display "[ -h|--help ]", and gives the following warning, due to a missing space:

troff: <standard input>:52: warning: macro 'B[' not defined

(Spotted while looking at Lintian errors . This doesn't actually fix the one identified there. That one seems to be S2_6 specific; I think it's caused by the long "freeciv-gtk2|freeciv-gtk3|freeciv-gtk3.22|freeciv-sdl|freeciv-sdl2|freeciv-qt|freeciv-xaw" in the SYNOPSIS, and earlier and later branches don't have so many client flavours. I don't know what if any formatting convention there is for a man page to document a lot of binaries which take the same options.)

m-30-26-freeciv-gtk322-man-fmt.patch (679 Bytes) m-30-26-freeciv-gtk322-man-fmt.patch Jacob Nevins, 2019-12-12 12:05 AM

Related issues

Related to Freeciv - Bug #767840: Debian lintian error about client manpage: cannot adjust lineClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Jacob Nevins about 1 year ago

#2 Updated by Marko Lindqvist about 1 year ago

  • Related to Bug #767840: Debian lintian error about client manpage: cannot adjust line added

#3 Updated by Jacob Nevins about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF