Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #857203

value "-1453617302" of type 'gint' is invalid (2.6.1+ (b36bc7dd48), gui-gtk-3.22, civ2civ3)

Added by Chippo Elder over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
gui-gtk-3
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Load the attached savegame. Get your Explorer [l tgt="unit" id=1647 name="Explorer" /] to explore tile [l tgt="tile" x=115 y=74 /].

In the console you get:
(freeciv-gtk3.22:1303584): GLib-GObject-WARNING **: 14:43:34.508: value "-1453617302" of type 'gint' is invalid or out of range for property 'weight' of type 'gint'

gint-bug.sav.bz2 (192 KB) gint-bug.sav.bz2 Chippo Elder, 2020-01-24 12:46 PM
m-gtk-weight-bold.patch (3.16 KB) m-gtk-weight-bold.patch master Jacob Nevins, 2020-01-25 11:57 PM
30-26-gtk-weight-bold.patch (3.15 KB) 30-26-gtk-weight-bold.patch S3_0, S2_6 Jacob Nevins, 2020-01-25 11:57 PM

History

#1 Updated by Jacob Nevins over 1 year ago

I couldn't reproduce it from savegame, but I could reproduce it otherwise after some trial and error. It shows up when launching the help dialog.

The underlying bug affects all Gtk clients, and looks like it's been there approximately forever.

I guess whether you see the message depends on how exactly a string address ends up translating to an integer.

#2 Updated by Chippo Elder over 1 year ago

Jacob Nevins wrote:

I couldn't reproduce it from savegame, but I could reproduce it otherwise after some trial and error. It shows up when launching the help dialog.

That Explorer move from the ticket, earns you some tech (from ancient scrolls). My client is configured to pull up the help dialog for new tech.

#3 Updated by Jacob Nevins over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF