Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #857638

Qt client discloses more intel for stacked units than singles (2.6.1+, classic)

Added by Chippo Elder 12 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Category:
gui-qt
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

In the attached screenshot, in the enemy stack of knights, I can see how many movement points they have. I've also middle-clicked on an allied warrior, but I don't see how many movement points he has.

Of course I know the warrior has 1 movement point, but the gui should be consistent and tell me this. Left-clicking on an unstacked unit does not bring up the stacked units dialog/windowlet/thingy.

no-movement-info.png (469 KB) no-movement-info.png Chippo Elder, 2020-01-28 04:44 PM
0002-Qt-Do-not-try-to-show-enemy-move-points.patch (2.32 KB) 0002-Qt-Do-not-try-to-show-enemy-move-points.patch Marko Lindqvist, 2020-04-16 06:16 AM
250

History

#1 Updated by Marko Lindqvist 12 months ago

I think the problem is worse than just UI inconsistency. I don't think client has correct information about how many movement points enemy units have left (it would be a bug if it does), so the stacked unit display is supposedly showing wrong numbers.
This also means that the correct way to fix this is to remove the movement points count from enemy (any owner but client owner) units from stacked units display.

#2 Updated by Chippo Elder 12 months ago

Of course. I feel quite silly. How about changing the Subject to something like 'qt gui incorrectly shows enemy MPs'?

#3 Updated by Marko Lindqvist 9 months ago

  • Tracker changed from Feature to Bug
  • Category set to gui-qt
  • Status changed from New to In Progress
  • Sprint/Milestone set to 2.6.3

#5 Updated by Marko Lindqvist 9 months ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

Also available in: Atom PDF