Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #861479

SDL climate change icons not updated sometimes

Added by Jacob Nevins 11 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
gui-sdl2
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

While investigating #861461 in the SDL-client, I noticed out of the corner of my eye that the warming / winter icons were appearing when I called dirty_all().

I guess they were generally stale.

I didn't reproduce trouble with the SDL2 client, but that is probably only luck.

m-30-sdl-climatechange-refresh.patch (889 Bytes) m-30-sdl-climatechange-refresh.patch master, S3_0 Jacob Nevins, 2020-02-22 11:00 PM
26-sdl-climatechange-refresh.patch (1.52 KB) 26-sdl-climatechange-refresh.patch S2_6 Jacob Nevins, 2020-02-22 11:00 PM

History

#1 Updated by Marko Lindqvist 11 months ago

Jacob Nevins wrote:

I didn't reproduce trouble with the SDL2 client, but that is probably only luck.

It could also be that they were fixed only in SDL2 in the initial development phase assuming they were regressions compared to SDL. I did some such fixes in this area, but can't say for sure this was one of them. At the time I were also unable to run sdl-client to check if things were broken also there.

#2 Updated by Jacob Nevins 11 months ago

I think the bug is probably still latent in the SDL2 client (since widget_mark_dirty() isn't being called after they are updated, and it is for nearby updates of other widgets).

#4 Updated by Jacob Nevins 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF