Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #861508

Don't prevent pillaging of extras caused by EC_POLLUTION/FALLOUT/HUT

Added by Jacob Nevins over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
General
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

It's possible to specify that an extra like Pollution can be removed by pillaging, and that causes the online help and menu sensitivity to make the pillage action possible, but when you choose it, nothing happens.

This is because get_preferred_pillage() doesn't consider every extra_cause, only extras caused by player activity and those with no cause; and this function acts as a gatekeeper to all pillaging.

Now that we have fine-grained rmcauses, there doesn't seem to be a good reason to restrict the pillage rmcause to "infrastructure" type extras.

(I bumped into this while testing another fix. I'm fixing this on 2.6 because that's where I am working, but a ruleset which wanted to actually take advange of this would need both an updated client and server, to stop the client self-censoring its ability to do the pillage.)

m-pillage-nuisance-etc.patch (2.8 KB) m-pillage-nuisance-etc.patch Jacob Nevins, 2020-02-23 05:19 PM
30-pillage-nuisance-etc.patch (2.8 KB) 30-pillage-nuisance-etc.patch Jacob Nevins, 2020-02-23 05:19 PM
26-pillage-nuisance-etc.patch (2.74 KB) 26-pillage-nuisance-etc.patch Jacob Nevins, 2020-02-23 05:19 PM

History

#1 Updated by Jacob Nevins over 1 year ago

Also, "Appear" and "Resource" on S3_0/master.

#2 Updated by Jacob Nevins over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF