Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #868533

clang-10 tautological-compare warnings

Added by Marko Lindqvist over 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Category:
General
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Some warnings seen when compiling with clang-10. I were compiling S3_0, but likely all branches are affected.

Will attach logs later.

errors.log (487 KB) errors.log Marko Lindqvist, 2020-04-10 09:02 AM
0006-debug.m4-Set-always-active-compiler-flags-last-not-f.patch (1.88 KB) 0006-debug.m4-Set-always-active-compiler-flags-last-not-f.patch Marko Lindqvist, 2020-04-22 03:04 AM

History

#1 Updated by Marko Lindqvist over 1 year ago

#2 Updated by Marko Lindqvist over 1 year ago

These tautological-compare errors come from generated sources (packets_gen.c, specenum_gen.h)

Either we need to fix the code generation (if it can be made safely) or to disable tautological-compare warnings.

#3 Updated by Marko Lindqvist over 1 year ago

  • Subject changed from clang-10 warnings to clang-10 tautological-compare warnings

Well, we already disable tautological-compare warnings, but apparently clang-10 does not care about it. Consider this a compiler bug? I don't have any good ideas for a workaround.

#4 Updated by Marko Lindqvist over 1 year ago

#5 Updated by Marko Lindqvist over 1 year ago

  • Sprint/Milestone set to 2.6.3

Ubuntu-20.04 LTS has clang-10, and warnings (or errors with --enable-debug) are coming up from all branches. However, there the warning seems to be more fine-grained type than already disabled tautological-compare, so we may can fix it by disabling that specific warning.

#6 Updated by Marko Lindqvist over 1 year ago

After some testing with different compiler commandlines makes me suspect that the problem is in order of the parameters. We set -Wno-tautological-compare before -Wall. Latter again enables the warning that former had disabled.

#8 Updated by Marko Lindqvist over 1 year ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

#9 Updated by Marko Lindqvist 11 months ago

  • Sprint/Milestone changed from 2.6.3 to 2.6.2.1

Also available in: Atom PDF