Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #871606

Revealing cities when establishing trade route does not reality_check_city() first

Added by Marko Lindqvist over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Server
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

I got an autogame error about existing plrtile city and updated city having different id. This is because reality_check_city() is not called to remove old city that used to exist on the same spot from the plrtile when the tile is revealed at unit_move()

History

#1 Updated by Marko Lindqvist over 1 year ago

This is with civ1 ruleset, if it matters (city centers can be next to each other). Moving unit is Musketeer.

I'm no longer sure the problem is in unit_move() itself (but it can be). Maybe the tile has been (or should have been) revealed earlier.

#2 Updated by Marko Lindqvist over 1 year ago

I think one place where reality_check_city() is not called when trade partner is revealed to a player when it establishes trade route.

So this could be triggered when:
1) Player 1 saw city A
2) Player 1 lost vision of city A
3) City A got destroyed, but remains in player 1's plrtile
4) City B gets established by player 2 on the same tile as city A formerly was
5) Player 2 establish traderoute from City B to a player 1's city. THE BUG: City A remains in player 1's plrtile
6) update_dump_city() for city B gets called for whatever reason. It detects that player 1 knows the city B, yet has city A in plrtile

#4 Updated by Marko Lindqvist over 1 year ago

  • Subject changed from Revealing cities in unit_move() does not reality_check_city() first to Revealing cities when establishing trade route does not reality_check_city() first

#5 Updated by Marko Lindqvist about 1 year ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

Also available in: Atom PDF