Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #879084

"Paradrop Unit" can sometimes invade during peace

Added by Sveinung Kvilhaugsvik over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Server
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

A non civilian unit can in certain situations paradrop deep into the territory of a player its owner has peace with. The unit then ends up unable to move at all.


Related issues

Related to Freeciv - Feature #879085: Obligatory no "Paradrop Unit" peace invasionClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Sveinung Kvilhaugsvik over 1 year ago

  • Related to Feature #879085: Obligatory no "Paradrop Unit" peace invasion added

#2 Updated by Sveinung Kvilhaugsvik over 1 year ago

  • Category changed from General to Server

The problem is that player map tile owner isn't set properly during savegame loading. The border is visible in the client but in the server player_tile owner is NULL.

#3 Updated by Sveinung Kvilhaugsvik over 1 year ago

Instructions to reproduce: Load attached save game. Take the player "o". Wait for the armistice to expire. Paradrop to a tile that is known but hasn't been seen after you loaded the savegame.

#5 Updated by Sveinung Kvilhaugsvik over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF