Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #879104

Illegal_Action_Move_Cost is triggered when trying to perform the illegal action doesn't reveal new information

Added by Sveinung Kvilhaugsvik 10 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Category:
Server
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

This bug is a part of the ruleset format for 2.6 and 3.0. I will therefore start by fixing it in 3.1 and give people a week to object to me fixing it in 3.0 too. Fixing it for 2.6 is probably way too late but the issue is present there too.

History

#1 Updated by Sveinung Kvilhaugsvik 10 months ago

Resolved for 3.1 only.

#2 Updated by Sveinung Kvilhaugsvik 10 months ago

  • Status changed from Resolved to In Progress

An argument for keeping this change master only is that the detection of what the player knows still don't recognize many situations where the player knows.

#3 Updated by Sveinung Kvilhaugsvik 9 months ago

#4 Updated by Sveinung Kvilhaugsvik 9 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF