Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #892147

Unfriendly do_log_deprecation() [../../src/utility/deprecations.c::65]: This action enabler is never used by any unit.

Added by Marko Lindqvist 11 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Category:
General
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

I get a deprecation warning about my ruleset:
do_log_deprecation() [../../src/utility/deprecations.c::65]: This action enabler is never used by any unit.

The problem is, I have no clue which action enabler "This" is. Would it be possible to include section name in the message?

History

#1 Updated by Marko Lindqvist 7 months ago

I get these a lot in my testing setup (where autogames with rulesets from various sources are running)

#2 Updated by Sveinung Kvilhaugsvik 7 months ago

Marko Lindqvist wrote:

I get a deprecation warning about my ruleset:
do_log_deprecation() [../../src/utility/deprecations.c::65]: This action enabler is never used by any unit.

The problem is, I have no clue which action enabler "This" is. Would it be possible to include section name in the message?

Section name would be ideal. We should at least include the action name. This wasn't done from the beginning because the messages originally were written for ruledit. Deprecation warnings started using the system later.

#3 Updated by Sveinung Kvilhaugsvik 6 months ago

Sveinung Kvilhaugsvik wrote:

Section name would be ideal. We should at least include the action name.

Action name included in attached patch.

#4 Updated by Sveinung Kvilhaugsvik 6 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF