Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #894434

sdl2: Road building button not enabled

Added by Marko Lindqvist 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Category:
gui-sdl2
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

sdl2-client never enables Road building button, though one can build road to the same tile with Connect-Road button.

The culprit seems to be the fact that first check "can_unit_do_activity(pUnit, ACTIVITY_GEN_ROAD)" is made without target while Road building is an activity which always requires target.

History

#2 Updated by Marko Lindqvist 6 months ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

#3 Updated by Marko Lindqvist 5 months ago

It works in 2.6.2, so this must have been regression since 2.6.2.

#4 Updated by Marko Lindqvist 5 months ago

Marko Lindqvist wrote:

It works in 2.6.2, so this must have been regression since 2.6.2.

At least for the Road part the code was changed opposite direction to this patch in Feature #861498

Also available in: Atom PDF