Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #898649

sdl2: Useless Toggle Mini Map Mode button

Added by Marko Lindqvist 6 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Category:
gui-sdl2
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

"Toggle Mini Map Mode" -button does nothing, and is documented so in code comments. Such a button really should not be exposed to user interface.

toggle_overview_mode():
/* FIXME: has no effect anymore */

Keyhandling:
/* toggle minimap mode - currently without effect */


Related issues

Precedes Freeciv - Feature #898699: Drop BORDERS_button from sdl2 theme formatClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Marko Lindqvist 6 months ago

  • Sprint/Milestone set to 2.6.3

Also sdl-client affected in S2_6.

#2 Updated by Marko Lindqvist 6 months ago

  • Precedes Feature #898699: Drop BORDERS_button from sdl2 theme format added

#3 Updated by Marko Lindqvist 6 months ago

S3_0 & S2_6 versions of the patch. I already encountered problems with the master version of the patch I have, so will submit working one later.

#6 Updated by Marko Lindqvist 5 months ago

Pushed to S2_6 & S3_0. In master I'm waiting for the coding style cleanup work to finish first.

#8 Updated by Marko Lindqvist 5 months ago

New master patch
- Rebased on top of Feature #910251
- Fixed a couple of places where the button was still considered to be part of widget array (update for other branches coming soon)

#9 Updated by Marko Lindqvist 5 months ago

- Fixed a couple of places where the button was still considered to be part of widget array (update for other branches coming soon)

S2_6 and S3_0 fixes attached. This is regression since 2.6.2, so still going to push for 2.6.3.

#10 Updated by Marko Lindqvist 5 months ago

Marko Lindqvist wrote:

- Fixed a couple of places where the button was still considered to be part of widget array (update for other branches coming soon)

S2_6 and S3_0 fixes attached. This is regression since 2.6.2, so still going to push for 2.6.3.

These pushed.

#11 Updated by Marko Lindqvist 4 months ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

Also available in: Atom PDF