Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #900565

S2_6 gtk3-client gtkpixcomm code does not build with gcc-11

Added by Marko Lindqvist 5 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
gui-gtk-3
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Building S2_6 gtk3-client gtkpixcomm stuff fails with gcc-11. I think the problem is in gtk+ headers, and not in freeciv code. That code is so badly deprecated, that I'm worried that upstream may not fix it any more. Maybe we need to backport changes needed for getting rid of gtkpixcomm to S2_6?


Related issues

Blocked by Freeciv - Feature #904733: S2_6 gtk3: Use GtkImage for indicator icons instead of GtkPixcommClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Blocked by Freeciv - Feature #905530: S2_6 gtk3: Use GtkImage instead of GtkPixcomm for diplomacy dialog flagsClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Blocked by Freeciv - Feature #906210: S2_6 gtk3: Use GtkImage instead of GtkPixcomm for happiness dialogClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Blocked by Freeciv - Feature #906539: S2_6 gtk3: Use GtkImage instead of GtkPixcomm for left panel unit iconsClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Blocked by Freeciv - Feature #906866: S2_6 gtk3: Replace GtkPixcomm based put_unit_gpixmap_city_overlays() with GtkImage based solutionsClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Blocked by Freeciv - Feature #908748: S2_6 gtk3: Use GtkImage instead of GtkPixcomm for citydlg citizen barClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Blocked by Freeciv - Feature #910393: S2_6 gtk3: Use GtkImage instead of GtkPixcomm for help itemClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Blocks Freeciv - Task #911624: Release 2.6.4Closed2021-04-012021-04-02

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Marko Lindqvist 4 months ago

  • Blocked by Feature #904733: S2_6 gtk3: Use GtkImage for indicator icons instead of GtkPixcomm added

#2 Updated by Marko Lindqvist 4 months ago

  • Blocked by Feature #905530: S2_6 gtk3: Use GtkImage instead of GtkPixcomm for diplomacy dialog flags added

#3 Updated by Marko Lindqvist 4 months ago

  • Blocked by Feature #906210: S2_6 gtk3: Use GtkImage instead of GtkPixcomm for happiness dialog added

#4 Updated by Marko Lindqvist 4 months ago

  • Blocked by Feature #906539: S2_6 gtk3: Use GtkImage instead of GtkPixcomm for left panel unit icons added

#5 Updated by Marko Lindqvist 4 months ago

  • Blocked by Feature #906866: S2_6 gtk3: Replace GtkPixcomm based put_unit_gpixmap_city_overlays() with GtkImage based solutions added

#6 Updated by Marko Lindqvist 4 months ago

Marko Lindqvist wrote:

That code is so badly deprecated, that I'm worried that upstream may not fix it any more.

OTOH, glib development snapshot 2.67.1 news in https://ftp.acc.umu.se/pub/GNOME/sources/glib/2.67/glib-2.67.1.news has an item that might affect that error:
"Remove `volatile` from various public APIs, including `G_DEFINE_*`. You should
adjust your code to not use `volatile` for atomic variables, `GOnce`
variables, or mostly anything else (see
http://isvolatileusefulwiththreads.in/c/). (#600)"

#7 Updated by Marko Lindqvist 4 months ago

From the original gna ticket about getting rid of gtkpixcomm ( https://web.archive.org/web/20170307062859/http://gna.org/patch/?6938 ), comments about why this was not done to S2_6 gtk3-client back then (here 'trunk' -> 3.0, 'gtk3x-client' -> gtk3.22-client):

I've been thinking about the S2_6 case.

- Introducing this patch series there is almost guaranteed to open up some corner cases. That's not nice in a branch that should be stabilizing already
- I'm worried that not introducing this series might cause us some trouble during the lifetime of S2_6. Yet, I can't say what exactly could break
- In trunk I'm about to bump minimum gtk3 version to 3.10, so that all the converting back and forth between formats can be avoided (implementations similar to gtk3x-client could be used). However, since S2_6 has msys1 as windows build environment, and the currently known good gtk3 package for it is 3.8, we can't bump requirement in S2_6 -> we would be stuck with the poor implementation.

Mainly because of the last point I'm removing S2_6 target from this.

#8 Updated by Marko Lindqvist 4 months ago

  • Blocked by Feature #908748: S2_6 gtk3: Use GtkImage instead of GtkPixcomm for citydlg citizen bar added

#9 Updated by Marko Lindqvist 4 months ago

  • Blocked by Feature #910393: S2_6 gtk3: Use GtkImage instead of GtkPixcomm for help item added

#10 Updated by Marko Lindqvist 4 months ago

#11 Updated by Marko Lindqvist 3 months ago

#12 Updated by Marko Lindqvist 3 months ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

Also available in: Atom PDF