Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #905573

msys2: MagickWand support not enabled

Added by Marko Lindqvist 10 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Category:
Windows Installers
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Noticed that configure on msys2 reports that MagickWand support cannot be enabled.

0047-Support-MagickWand-7.patch (2.25 KB) 0047-Support-MagickWand-7.patch Marko Lindqvist, 2020-12-12 03:56 PM
0020-Support-MagickWand-7.patch (3.38 KB) 0020-Support-MagickWand-7.patch master, S3_0 Marko Lindqvist, 2020-12-21 10:21 PM
0001-Support-MagickWand-7.patch (3.59 KB) 0001-Support-MagickWand-7.patch S2_6 Marko Lindqvist, 2020-12-27 05:06 AM

Related issues

Related to Freeciv - Feature #896715: Msys2-next after 200906Closed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Marko Lindqvist 10 months ago

#2 Updated by Marko Lindqvist 10 months ago

  • Status changed from New to In Progress
  • Sprint/Milestone set to 2.6.4

I have similar problem also in Manjaro virtual machine. I have not confirmed that msys2 has the same issue, but in Manjaro's case the problem is that it has ImageMagick-7 (out for years already, but most distributions still prefer ImageMagick-6), and freeciv does not support it.
Taking this ticket for implementing ImageMagick-7 support.

#3 Updated by Marko Lindqvist 10 months ago

It's likely that this causes msys2 builds to start to depend on new dlls that installer build should include. Thus this cannot be pushed until msys2 build from each branch is tested, which likely happen only after we've got 3.0.0-alpha5 and 2.6.3 releases out of the way.

#4 Updated by Marko Lindqvist 10 months ago

Marko Lindqvist wrote:

I have not confirmed that msys2 has the same issue,

Now I have. The MagickWand-7 fix solves also msys2 configure failure. This is no longer blocking new msys2 environment.

#5 Updated by Marko Lindqvist 10 months ago

  • Status changed from Resolved to In Progress

Marko Lindqvist wrote:

It's likely that this causes msys2 builds to start to depend on new dlls that installer build should include.

Confirmed that dll lists need work.

#6 Updated by Marko Lindqvist 10 months ago

Commit candidate patch for master. Will push this already while waiting opportunity to finish patches for other branches.

#7 Updated by Marko Lindqvist 10 months ago

Marko Lindqvist wrote:

Commit candidate patch for master. Will push this already while waiting opportunity to finish patches for other branches.

Same patch applies to S3_0, so will push there too.

#8 Updated by Marko Lindqvist 10 months ago

Pushed to master.

#9 Updated by Marko Lindqvist 10 months ago

Pushed to S3_0

#10 Updated by Marko Lindqvist 10 months ago

S2_6 version with msys2 dll lists updated

#11 Updated by Marko Lindqvist 10 months ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

Also available in: Atom PDF