Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #905818

Only one track plays of the selected style

Added by Marko Lindqvist 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Category:
Client
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

jwrober reported in http://forum.freeciv.org/f/viewtopic.php?f=15&t=91331:

"The main issue is that while in either peace or combat, only one song plays and then the music stops."

The problem seems to be the switching_usage variable that is supposed to prevent music ending callback from starting a new track when music of the style is intentionally stopped. That's not only unnecessary, but actually breaks things. Callback does not get called at all when music is intentionally stopped. Thus the switching_usage is not cleared. Once stopping of menu music sets switching_usage, it remains until callback is called in the game, causing it to think that music should not continue.


Related issues

Blocks Freeciv - Task #896713: S3_0-alpha5Closed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Marko Lindqvist 8 months ago

#2 Updated by Marko Lindqvist 8 months ago

#3 Updated by Marko Lindqvist 8 months ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

#4 Updated by Marko Lindqvist 7 months ago

Marko Lindqvist wrote:

The problem seems to be the switching_usage variable that is supposed to prevent music ending callback from starting a new track when music of the style is intentionally stopped. That's not only unnecessary, but actually breaks things. Callback does not get called at all when music is intentionally stopped. Thus the switching_usage is not cleared. Once stopping of menu music sets switching_usage, it remains until callback is called in the game, causing it to think that music should not continue.

This analysis might have been wrong, and the actual root cause being Bug #910605. The reason callback was not called was that it was not set at all for single "music_menu" track. It seems that together this removal of "switching_usage" variable and fix to Bug #910605 cause menu music not to stop when entering game if there's no in-game music to override it.
I don't think we need to touch (revert) this before 2.6.3 any more, as lack of fix for Bug #910605 mitigates the problem. I'll open a new ticket about reverting this after 2.6.3.

#5 Updated by Marko Lindqvist 7 months ago

Marko Lindqvist wrote:

I'll open a new ticket about reverting this after 2.6.3.

-> Bug #910919

Also available in: Atom PDF