Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Task #911624

Release 2.6.4

Added by Marko Lindqvist over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Milestone
Sprint/Milestone:
Start date:
2021-04-01
Due date:
2021-04-02
% Done:

0%

Estimated time:

Description

We have targeted gcc-11 related compile issue Bug #900565 to 2.6.4. So I think we should aim to release 2.6.4 around the time gcc-11 gets released, late April.


Related issues

Related to Freeciv - Deliverable #924629: Windows (msys1) packages for 2.6.4Closed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Related to Freeciv - Deliverable #924630: Windows (msys2) packages for 2.6.4Closed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Blocked by Freeciv - Bug #900565: S2_6 gtk3-client gtkpixcomm code does not build with gcc-11Closed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Blocked by Freeciv - Feature #918825: Msys2-next after 201212Closed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Blocked by Freeciv - Task #922927: Update S2_6 git modpack snapshotsClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Blocked by Freeciv - Bug #914184: The game seed has zero entropy if one knows the game start timeClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Marko Lindqvist over 1 year ago

  • Blocked by Bug #900565: S2_6 gtk3-client gtkpixcomm code does not build with gcc-11 added

#2 Updated by Marko Lindqvist over 1 year ago

#3 Updated by Marko Lindqvist over 1 year ago

  • Blocked by Task #922927: Update S2_6 git modpack snapshots added

#4 Updated by Marko Lindqvist over 1 year ago

  • Blocked by Bug #914184: The game seed has zero entropy if one knows the game start time added

#5 Updated by Marko Lindqvist over 1 year ago

  • Due date set to 2021-04-02
  • Assignee set to Marko Lindqvist
  • Start date set to 2021-04-01

#6 Updated by Marko Lindqvist about 1 year ago

Regression since 2.6.3: https://osdn.net/projects/freeciv/ticket/41860

I'm not sure yet if I can handle the release in planned schedule after we need to wait for a fix for that one to be handled before going forward with the preparations.

#7 Updated by Marko Lindqvist about 1 year ago

New release blocker, threaded AI does not build: https://osdn.net/projects/freeciv/ticket/41870

#8 Updated by Marko Lindqvist about 1 year ago

Tag pushed. S2_6 is open for 2.6.5 commits.

#9 Updated by Marko Lindqvist about 1 year ago

#10 Updated by Marko Lindqvist about 1 year ago

#11 Updated by Marko Lindqvist about 1 year ago

  • Status changed from New to Closed

Also available in: Atom PDF