Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #918726

Big stacks kill the connection

Added by Louis Moureaux 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Category:
General
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Simple repro case, confirmed in 2.6.2 but players mentioned it with 2.6.3 as well:

  • Start a local game with 2+ players, default everything
  • Add a big stack with the editor (100+ units)
  • Add a second big stack next to it, owned by a different nation
  • Client disconnects

There are two bugs:

  • The server spams thousands of PLAYER_DIPL_STATE packets (maybe one for every unit pair, didn't check)
  • These repeated packets compress very well (something like 150x). Client side, the default buffer of 80x the compressed data is insufficient, and the code fails to grow it because it does it on Z_DATA_ERROR and zlib returns Z_BUF_ERROR

This affects a running game with Corbeau's Simulation ruleset, where the AI creates big stacks of hundreds of units (the stacks are useless but the purpose of adding AIs in the first place was to have some dumb players to fight with). Moving a single unit next to such a stack can trigger the issue.

History

#2 Updated by Marko Lindqvist 6 months ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

#3 Updated by Louis Moureaux 6 months ago

No fix for the server spamming thousands of identical packets? Old clients will stay around for a while.

#4 Updated by Marko Lindqvist 6 months ago

Louis Moureaux wrote:

No fix for the server spamming thousands of identical packets?

Open a separate ticket about that. One bug / ticket. Patches welcome.

Also available in: Atom PDF