Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. *Read more...*

Bug #954662

closed

Исправлены ошибки обращения к ячейкам колонок сгенерированной на странице "Дерево" таблицы значений с очень длинным именем

Added by Сергей Старых 13 days ago. Updated 8 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Редактор текста
Sprint/Milestone:
Start date:
2022-01-01
Due date:
% Done:

0%

Estimated time:

Description

Исправлено путем ограничения максимальной длинны автоимени колонки.

<template xmlns="http://dobop.ru/esb/cc/2015/01" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" comment="" folderId="3b7788da-a197-4b16-acf0-4bdb0f7589cb" name="ПланПоступления_WMSIN" templateData="&lt;template1C xmlns=&quot;http://axelot.ru/esb/cc/2015/01&quot; xmlns:xs=&quot;http://www.w3.org/2001/XMLSchema&quot; xmlns:xsi=&quot;http://www.w3.org/2001/XMLSchema-instance&quot; name=&quot;ПланПоступления_WMSIN&quot; type=&quot;Входящая&quot; version=&quot;44&quot;&gt;
    &lt;ingoingSettings messageClassId=&quot;52&quot; messageClassName=&quot;ПланПоступления&quot;/&gt;
    &lt;code&gt;&amp;#9;//ИмяТаблицыБазыОбмена=dbo_inReceiptPlan&amp;#10;&amp;#9;&amp;#9;&amp;#10;&amp;#9;//Определение переменных&amp;#10;&amp;#9;Локализация = &quot;ru&quot;;&amp;#10;&amp;#9;КлассПакета_Номенклатура = 3;&amp;#10;&amp;#9;КлассПакета_Контрагент = 5;&amp;#10;&amp;#9;КлассПакета_ВидДоставки = 6;&amp;#10;&amp;#9;КлассПакета_Договор = 7;&amp;#10;&amp;#9;КлассПакета_УпаковкаНоменклатуры = 10;&amp;#10;&amp;#9;КлассПакета_Партия = 11;&amp;#10;&amp;#9;КлассПакета_Состояния = 12;&amp;#10;&amp;#9;КлассПакета_Характеристика = 13;&amp;#10;&amp;#9;КлассПакета_Спецификация = 14;&amp;#10;&amp;#9;КлассПакета_ТипПоступления = 9;&amp;#10;&amp;#9;КлассПакета_ТС = 19;&amp;#10;&amp;#9;КлассПакета_Физлицо = 21;&amp;#10;&amp;#9;КлассПакета_ПланОтгрузки = 51;&amp;#10;&amp;#9;КлассПакета_ПланПоступления = 52;&amp;#10;&amp;#9;КлассПакета_Рейс = 53;&amp;#10;&amp;#9;КлассПакета_Организация = 23;&amp;#10;&amp;#10;&amp;#9;сткСообщение = Новый Структура(&quot;СостояниеСообщения, ТекстОшибки, КоличествоПопытокОжидания, Задержка, Отказ, Узел, СоответствиеНеНайденныхИдентификаторов&quot;, СостояниеСообщения, ТекстОшибки, КоличествоПопытокОжидания,&amp;#10;&amp;#9;&amp;#9;Задержка, Ложь, ОбъектСообщение.Source, Новый Соответствие);&amp;#10;&amp;#9;&amp;#9;&amp;#9;&amp;#9;&amp;#9;&amp;#10;&amp;#9;// Получение тела сообщения&amp;#10;&amp;#9;xdtoОбъект = сшпОбщегоНазначения.ПолучитьОбъектXDTO(ФорматСообщения, ОбъектСообщение.Body);&amp;#10;&amp;#10;&amp;#9;//Получение полей&amp;#10;&amp;#9;СсылкаXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'Ссылка'; en = 'ID'&quot;, Локализация));&amp;#10;&amp;#9;ДатаРегистрацииXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'ДатаРегистрации'; en = 'RegistrationDate'&quot;, Локализация));&amp;#10;&amp;#9;ПометкаУдаленияXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'ПометкаУдаления'; en = 'DeletionMark'&quot;, Локализация));&amp;#10;&amp;#9;ПроведенXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'Проведен'; en = 'Posted'&quot;, Локализация));&amp;#10;&amp;#9;ТипПоступленияXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'ТипПоступления'; en = 'ReceivingType'&quot;, Локализация));&amp;#10;&amp;#9;ТранспортноеСредствоXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'ТранспортноеСредство'; en = 'Vehicle'&quot;, Локализация));&amp;#10;&amp;#9;ВодительXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'Водитель'; en = 'Driver'&quot;, Локализация));&amp;#10;&amp;#9;МенеджерXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'Менеджер'; en = 'Manager'&quot;, Локализация));&amp;#10;&amp;#9;ВидДоставкиXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'ВидДоставки'; en = 'DeliveryType'&quot;, Локализация));&amp;#10;&amp;#9;ДатаXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'Дата'; en = 'Date'&quot;, Локализация));&amp;#10;&amp;#9;ДатаПоступленияXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'ДатаПоступления'; en = 'ReceiptDate'&quot;, Локализация));&amp;#10;&amp;#9;РейсXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'Рейс'; en = 'Delivery'&quot;, Локализация));&amp;#10;&amp;#9;ЗаказНаОтгрузкуXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'ЗаказНаОтгрузку'; en = 'ShippingOrder'&quot;, Локализация));&amp;#10;&amp;#9;КомментарийXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'Комментарий'; en = 'Comment'&quot;, Локализация));&amp;#10;&amp;#9;КонтрагентXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'Контрагент'; en = 'BusinessPartner'&quot;, Локализация));&amp;#10;&amp;#9;НомерXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'Номер'; en = 'Number'&quot;, Локализация));&amp;#10;&amp;#9;ОрганизацияXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'Организация'; en = 'Owner'&quot;, Локализация));&amp;#10;&amp;#9;ПриоритетXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'Приоритет'; en = 'Priority'&quot;, Локализация));&amp;#10;&amp;#9;ДоговорXDTO = xdtoОбъект.Получить(НСтр(&quot;ru = 'Договор'; en = 'Contract'&quot;, Локализация));&amp;#10;&amp;#10;&amp;#9;//Поиск объекта&amp;#10;&amp;#9;ЛокальныйИдентификатор_Ссылка = ИнтеграцияСервер.ПолучитьЛокальныйИдентификатор(СсылкаXDTO, КлассПакета_ПланПоступления, сткСообщение.Узел);&amp;#10;&amp;#9;СсылкаНаЭлемент = Документы.ПланПоступления.ПолучитьСсылку(Новый УникальныйИдентификатор(ЛокальныйИдентификатор_Ссылка));&amp;#10;&amp;#10;&amp;#9;ЭтоНовый = Ложь;&amp;#10;&amp;#9;новыйОбъект = СсылкаНаЭлемент.ПолучитьОбъект();&amp;#10;&amp;#9;Если новыйОбъект = Неопределено Тогда&amp;#10;&amp;#9;&amp;#9;новыйОбъект = Документы.ПланПоступления.СоздатьДокумент();&amp;#10;&amp;#9;&amp;#9;новыйОбъект.УстановитьСсылкуНового(СсылкаНаЭлемент);&amp;#10;&amp;#9;&amp;#9;новыйОбъект.Дата = ТекущаяДата();&amp;#10;&amp;#9;&amp;#9;ЭтоНовый = Истина;&amp;#10;&amp;#9;&amp;#9;ИсходныйСтатус = Справочники.СтатусыДокументов.Новый;&amp;#10;&amp;#9;&amp;#9;новыйОбъект.ДатаЗагрузки = ИнтеграцияСервер.ПолучитьДату(ДатаРегистрацииXDTO);&amp;#10;&amp;#9;Иначе&amp;#10;&amp;#9;&amp;#9;ИсходныйСтатус = СтатусыДокументовСервер.СтатусДокументаПоСсылке(СсылкаНаЭлемент);&amp;#10;&amp;#9;&amp;#9;ДатаЗагрузки = ИнтеграцияСервер.ПолучитьДату(ДатаРегистрацииXDTO);&amp;#10;&amp;#9;&amp;#9;Если новыйОбъект.ДатаЗагрузки &amp;gt; ДатаЗагрузки Тогда&amp;#10;&amp;#9;&amp;#9;&amp;#9;СостояниеСообщения = Перечисления.сшпСтатусыСообщений.ОбработкаОтменена;&amp;#10;&amp;#9;&amp;#9;&amp;#9;Перейти ~Выход;&amp;#10;&amp;#9;&amp;#9;Иначе&amp;#10;&amp;#9;&amp;#9;&amp;#9;новыйОбъект.ДатаЗагрузки = ДатаЗагрузки;&amp;#10;&amp;#9;&amp;#9;КонецЕсли;&amp;#9;&amp;#10;&amp;#9;КонецЕсли;&amp;#10;&amp;#10;&amp;#9;Если ИсходныйСтатус = Справочники.СтатусыДокументов.Обрабатывается Тогда&amp;#10;&amp;#9;&amp;#9;сткСообщение.Отказ = Истина;&amp;#10;&amp;#9;&amp;#9;СостояниеСообщения = Перечисления.сшпСтатусыСообщений.ОжиданиеОбработки;&amp;#10;&amp;#9;&amp;#9;Перейти ~Выход;&amp;#10;&amp;#9;КонецЕсли;&amp;#10;&amp;#10;&amp;#9;//Реквизиты шапки&amp;#10;&amp;#9;...&gt;
    &lt;comment/&gt;
    &lt;variables/&gt;
&lt;/template1C&gt;" type="_1C" uuid="0f6b39e1-e7e3-4934-b80b-d7d6e5ac1d40" version="44"/>


Files

clipboard-202211231617-dwnz7.png (17.5 KB) clipboard-202211231617-dwnz7.png Сергей Старых, 2022-11-23 02:17 PM
Actions #1

Updated by Сергей Старых 13 days ago

  • Description updated (diff)
Actions #2

Updated by Сергей Старых 10 days ago

  • Subject changed from Ошибка обращения к ячейкам колонки таблицы значений с очень длинным именем to Исправлены ошибки к ячейкам колонок таблицы значений с очень длинным именем
  • Description updated (diff)
  • Status changed from New to Closed
Actions #3

Updated by Сергей Старых 10 days ago

  • Subject changed from Исправлены ошибки к ячейкам колонок таблицы значений с очень длинным именем to Исправлены ошибки обращения к ячейкам колонок сгенерированной на странице "Дерево" таблицы значений с очень длинным именем
Actions #4

Updated by Сергей Старых 10 days ago

  • Description updated (diff)
Actions #5

Updated by Сергей Старых 10 days ago

  • Start date set to 2022-01-01
Actions #6

Updated by Сергей Старых 8 days ago

  • Sprint/Milestone changed from Разработка to 6.54.1

Also available in: Atom PDF