Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. *Read more...*

Bug #957225

open

8.2-3.23+ В табличном поле не делается горизонтальная прокрутка при программной активации колонки

Added by Сергей Старых 14 days ago. Updated 14 days ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

https://partners.v8.1c.ru/forum/t/2105061/m/2105061
Конфигурация ПО

8.2-3.23+, обычная форма

Проблема

В табличном поле не делается горизонтальная прокрутка при программной активации колонки, которой предшествуют невидимые колонки

Воспроизведение

Запустить обычное клиентское приложение в любой базе. Открыть в нем приложенную внешнюю обработку. Откроется форма с табличным полем с одной строкой и 7-ю колонками. Часть колонок табличного поля находится за пределами видимой горизонтальной области. Колонки 5 и 6 невидимы. Нажимать кнопку "Следующий" многократно. При этом будет выполняться код активации следующей видимой колонки
Процедура След(Кнопка = Неопределено)
Колонки = ЭлементыФормы.ТабличноеПоле1.Колонки;
Индекс = Колонки.Индекс(ЭлементыФормы.ТабличноеПоле1.ТекущаяКолонка);
Пока Индекс < Колонки.Количество() - 1 Цикл
СледКолонка = Колонки[Индекс + 1];
Если СледКолонка.Видимость Тогда
ЭлементыФормы.ТабличноеПоле1.ТекущаяКолонка = СледКолонка;
Прервать;
КонецЕсли;
Индекс = Индекс + 1;
КонецЦикла;
КонецПроцедуры

Ожидаем что при активации каждой колонки полоса прокрутки будет смещаться вправо, чтобы колонка попадала в видимую область поля. Однако при активной колонке 5 нажатие кнопки хотя и активирует колонку 8, но прокрутки не происходит и она остается за пределами видимой области.

Обход проблемы

Запомнить все предшествующие невидимые колонки, сделать их видимыми, активировать нужную колонку, вернуть невидимость запомненных колонок.


Files

clipboard-202301221304-cplxk.png (37.5 KB) clipboard-202301221304-cplxk.png Сергей Старых, 2023-01-22 11:04 AM
clipboard-202301221304-vozjf.png (11.8 KB) clipboard-202301221304-vozjf.png Сергей Старых, 2023-01-22 11:04 AM
clipboard-202301221304-mcz8e.png (11.8 KB) clipboard-202301221304-mcz8e.png Сергей Старых, 2023-01-22 11:04 AM
ОтважныйБобр.epf (8.77 KB) ОтважныйБобр.epf Сергей Старых, 2023-01-22 11:22 AM

Related issues

Related to Инструменты разработчика Tormozit для 1С - Bug #957222: Исправлена активация колонки связанного табличного поля обычной формы из окна "Колонки табличного поля" и "Структура формы"Closed

Actions
Actions #1

Updated by Сергей Старых 14 days ago

  • Description updated (diff)
Actions #2

Updated by Сергей Старых 14 days ago

  • Related to Bug #957222: Исправлена активация колонки связанного табличного поля обычной формы из окна "Колонки табличного поля" и "Структура формы" added
Actions #3

Updated by Сергей Старых 14 days ago

  • Description updated (diff)
Actions #4

Updated by Сергей Старых 14 days ago

  • File deleted (ОтважныйБобр.epf)
Actions #6

Updated by Сергей Старых 14 days ago

  • Description updated (diff)

Also available in: Atom PDF