Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #984781

open

8.3.25 Аварийное завершение клиентского приложения при клике в поле HTML обычной и управляемой формы

Added by Сергей Старых 3 months ago. Updated 3 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

https://partners.v8.1c.ru/forum/topic/2185342
Конфигурация ПО

1С 8.3.25.1257, обычная и управляемая формы

Проблема

Аварийное завершение клиентского приложения при клике в поле HTML обычной и управляемой формы

Воспроизведение

Открыть приложенную внешнюю обработку в любой базе в обычном клиентском приложении. Нажать кнопку "Выполнить". При этом выполнится код

Процедура КнопкаВыполнитьНажатие(Кнопка)
//я = ЭлементыФормы.ПолеHTMLДокумента1.Документ.НесуществующееСвойство;
ЭлементыФормы.ПолеHTMLДокумента1.УстановитьТекст("<html><body>Хотун импертон</body></html>");
КонецПроцедуры

Процедура ПолеHTMLДокумента1ДокументСформирован(Элемент)
ДобавитьОбработчик ЭлементыФормы.ПолеHTMLДокумента1.Документ.defaultView.onclick, ЭтаФорма.РедакторHTMLonclick;
КонецПроцедуры

Процедура РедакторHTMLonclick(ДанныеСобытия) Экспорт
КонецПроцедуры

В поле HTML документа начать кликать в случайные места до аварийного завершения программы. Показано на видеоролике.

Повторить тест в управляемом приложении. Но там надо покликать раз 10-20 и закрыть форму. При закрытии формы также произойдет аварийное завершение.

В 8.3.24.1368 проблема не воспроизводится.

Родственные темы

https://partners.v8.1c.ru/forum/topic/2125498#m_2125498
https://partners.v8.1c.ru/forum/topic/2027255#m_2027255


Files

ОтважныйБобр.epf (279 KB) ОтважныйБобр.epf Сергей Старых, 2024-04-23 11:22 PM
KXZYSJYtU8.mp4 (653 KB) KXZYSJYtU8.mp4 Сергей Старых, 2024-04-23 11:22 PM

Related issues

Related to Инструменты разработчика Tormozit для 1С - Bug #984942: Исправлено аварийное завершение программы при использовании HTML редактора во всех инструментах на 8.3.25 Closed

Actions
Actions #1

Updated by Сергей Старых 3 months ago

  • Description updated (diff)
Actions #2

Updated by Сергей Старых 3 months ago

  • Related to Bug #984942: Исправлено аварийное завершение программы при использовании HTML редактора во всех инструментах на 8.3.25 added

Also available in: Atom PDF