Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #984784

open

В обычной форме поле HTML вызывает обновление всех табличных полей формы при клике по нему

Added by Сергей Старых 3 months ago. Updated about 2 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

https://partners.v8.1c.ru/forum/t/2185368/m/2185368
https://bugboard.v8.1c.ru/error/000155815
Конфигурация ПО

1С 8.2-3.25, обычная форма

Проблема

В обычной форме поле HTML вызывает обновление всех табличных полей формы при клике по нему при наличии статического обработчика onclick

Воспроизведение

Открыть приложенную внешнюю обработку в любой базе в обычном клиентском приложении. Начать кликать левой кнопкой мыши в поле HTML с текстом "Хотун импертон". У этого поля подключен статический обработчик onclick. При этом будет выполнятся код обработчика ПриВыводеСтроки табличного поля и выводиться сообщение "ПриВыводеСтроки".

Процедура ТабличноеПоле1ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
Сообщить("ПриВыводеСтроки");
КонецПроцедуры

А ожидалось, что обработчик ПриВыводеСтроки не будет вызываться.

Способ обхода

Подключать обработчик onclick не статически, а динамически

Процедура ПолеHTMLДокумента1ДокументСформирован(Элемент)
ДобавитьОбработчик ЭлементыФормы.ПолеHTMLДокумента1.Документ.defaultView.onclick, ЭтаФорма.РедакторHTMLonclick;
КонецПроцедуры

Процедура РедакторHTMLonclick(ДанныеСобытия) Экспорт
КонецПроцедуры

Особо подчеркну, что событие нужно брать Документ.defaultView.onclick, а не Документ.onclick, которое молча выполняет подключение обработчика, но он почему то не вызывается.
Но это влечет ряд других проблем сильно зависящих от версии платформы. Например разнообразные аварийные завершения приложения

https://partners.v8.1c.ru/forum/topic/2125498#m_2125498
https://partners.v8.1c.ru/forum/topic/2027255#m_2027255
https://partners.v8.1c.ru/forum/t/2185342/m/2185342
https://github.com/salexdv/bsl_console/issues/178


Files

ОтважныйБобр.epf (279 KB) ОтважныйБобр.epf Сергей Старых, 2024-04-24 07:47 AM
clipboard-202404240848-rqabx.png (39.4 KB) clipboard-202404240848-rqabx.png Сергей Старых, 2024-04-24 07:48 AM
clipboard-202404240848-c7i1n.png (15.3 KB) clipboard-202404240848-c7i1n.png Сергей Старых, 2024-04-24 07:48 AM

Related issues

Related to Инструменты разработчика Tormozit для 1С - Bug #984942: Исправлено аварийное завершение программы при использовании HTML редактора во всех инструментах на 8.3.25 Closed

Actions
Actions #1

Updated by Сергей Старых 3 months ago

  • Description updated (diff)
Actions #2

Updated by Сергей Старых 3 months ago

  • Description updated (diff)
Actions #3

Updated by Сергей Старых 3 months ago

  • Description updated (diff)
Actions #4

Updated by Сергей Старых 3 months ago

  • Description updated (diff)
Actions #5

Updated by Сергей Старых 3 months ago

  • Description updated (diff)
Actions #6

Updated by Сергей Старых 3 months ago

  • Related to Bug #984942: Исправлено аварийное завершение программы при использовании HTML редактора во всех инструментах на 8.3.25 added
Actions #7

Updated by Сергей Старых 3 months ago

  • Description updated (diff)
Actions #8

Updated by Сергей Старых about 2 months ago

  • Description updated (diff)

Also available in: Atom PDF