Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #986658

open

Сбрасываются свойства кнопок в таблицах формы после серверного вызова с добавлением таблицы

Added by Сергей Старых about 1 month ago. Updated 23 days ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

https://partners.v8.1c.ru/forum/t/2190443/m/2190443
https://bugboard.v8.1c.ru/error/000157688
Конфигурация ПО

8.3.23-25

Проблема

Сбрасываются свойства кнопок в таблицах формы после серверного вызова с добавлением таблицы

Воспроизведение

Открыть приложенную внешнюю обработку в управляемом клиентском приложении любой базы. При этом выполнится код
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Элементы.Реквизит3КонтекстноеМеню.ПодчиненныеЭлементы1.Доступность = Ложь;
КонецПроцедуры

И кнопка "Расширенный поиск" в контекстном меню таблицы станет недоступной.
Нажать Команда1. При этом выполнится код
&НаКлиенте
Процедура Команда1(Команда)
Тест();
Сообщить(Элементы.Реквизит3КонтекстноеМеню.ПодчиненныеЭлементы1.Доступность);
КонецПроцедуры

&НаСервере
Процедура Тест() Экспорт
Элементы.Добавить("ф", Тип("ТаблицаФормы"), ЭтотОбъект);
КонецПроцедуры

И кнопка "Расширенный поиск" становится доступной и выводится соответствующее сообщение "Да".
Ожидалось, что кнопка не изменит своего состояния.

Способ обхода

Сохранять все доступности кнопок формы перед серверным вызовом с добавлением таблицы формы и после него восстанавливать
СтарыеДоступности = Новый Структура;
Для Каждого Элемент Из Элементы Цикл
Если ТипЗнч(Элемент) = Тип("КнопкаФормы") Тогда
СтарыеДоступности.Вставить(Элемент.Имя, Элемент.Доступность);
КонецЕсли;
КонецЦикла;
... // Серверный вызов
Для Каждого КлючИЗначение Из СтарыеДоступности Цикл
Элементы[КлючИЗначение.Ключ].Доступность = КлючИЗначение.Значение;
КонецЦикла;


Files

clipboard-202406061706-ug0bo.png (15 KB) clipboard-202406061706-ug0bo.png Сергей Старых, 2024-06-06 04:06 PM
clipboard-202406061706-bjad4.png (13.1 KB) clipboard-202406061706-bjad4.png Сергей Старых, 2024-06-06 04:06 PM
ОтважныйБобр.epf (280 KB) ОтважныйБобр.epf Сергей Старых, 2024-06-06 04:06 PM

Also available in: Atom PDF